Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#6537 closed defect (fixed)

SCI: JONES - save / restore game grayed in top menu

Reported by: misterhands Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Jones in the Fast Lane

Description

Latest win64 nightly
Jones CD DOS ENG, may affect floppy version too.

After loading a savegame from the in-game menu, "Save game" and "Restore game" are grayed in the top menu. Sometimes after saving or loading, only restore is grayed.

This does not occur under DOSBox.

Ticket imported from: bugs/6537.

Attachments (2)

Grayed1.png (17.4 KB ) - added by misterhands 6 years ago.
Grayed2.png (15.8 KB ) - added by misterhands 6 years ago.

Download all attachments as: .zip

Change History (6)

by misterhands, 6 years ago

Attachment: Grayed2.png added

comment:1 by bluegr, 5 years ago

Owner: set to bluegr
Resolution: worksforme
Status: newpending

comment:2 by bluegr, 5 years ago

I can't reproduce this from the in-game menu. I can only replicate this from the ScummVM launcher menu, like in bug #6723.

Setting this to "pending". If you can reliably reproduce this from the in-game menu, please say so. Otherwise, this can be closed, and we can continue the bug fixing in bug #6723 instead.

comment:3 by misterhands, 5 years ago

I confirm that this still occurs for me with a build from today, when loading from the game main menu. By that I mean the big blue button labeled RESTORE GAME, not the top menu which seems to work fine.

In that case, the About and Help menu options are ok (except when loading from ScummVM launcher), but Save, Restore, Delete Current Player (there are 3 players in the saved game), Statistics and Goals are disabled.

comment:4 by bluegr, 5 years ago

Resolution: worksformefixed
Status: pendingclosed

comment:5 by bluegr, 5 years ago

Right, I've pinpointed the issue, but it's quite a pain to patch the relevant code. Thus, these menu entries are now always enabled after a game is loaded from the main menu.

Fixed (with a hack) in commit 1d5536d. The fix should be available in the next daily version of ScummVM.

Closing

Note: See TracTickets for help on using tickets.