Opened 6 years ago

Closed 2 years ago

Last modified 3 months ago

#6527 closed defect (fixed)

WME: J.U.L.I.A. - Assertion when landing on the planet

Reported by: raziel- Owned by: somaen
Priority: normal Component: Engine: Wintermute
Keywords: Cc:
Game: Wintermute

Description

ScummVM 1.7.0git (Feb 6 2014 15:42:12)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

I get this assertion in J.U.L.I.A. when sending the Mobot to the planet surface.
Background music is playing while the beautiful surface view is shown, nothing else though.

assertion "_str && idx >= 0 && idx < (int)_size" failed: file "./common/ustr.h", line 128

J.U.L.I.A. (fangame) (Windows)

Amiga OS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: bugs/6527.

Attachments (1)

julia-win.001 (172.0 KB ) - added by raziel- 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 by somaen, 6 years ago

Component: Engine: Wintermute
Game: Wintermute

comment:2 by somaen, 6 years ago

I'm curious as to your version of the game, since it detects as (fangame).

Currently "(fangame)" is my (rather poorly) chosen way of saying "This game does not have an explicit detection entry, so we simply looked into any available dcp-files for the necessary files to launch, and grabbed the window-title as a game-title".

Where did you get this version from, and what language is it?

comment:3 by raziel-, 6 years ago

I'm not sure if it is anywhere else available but from STEAM.
I didn't put much effort into finding another site that may offer it after i found it there :-)

It's the english pc version

by raziel-, 6 years ago

Attachment: julia-win.001 added

comment:4 by raziel-, 6 years ago

Adding a save game just before the assertion (just land the MoBot)

comment:5 by raziel-, 6 years ago

I am not able to reproduce this assertion anymore.

Neither with the save state nor with playing from start, so i guess this is fixed :-)

comment:6 by somaen, 5 years ago

Owner: set to somaen

comment:7 by csnover, 2 years ago

Resolution: fixed
Status: newclosed

According to previous comment, this bug was fixed but never closed.

comment:8 by lolbot-iichan, 3 months ago

Summary: WME: Assertion when landing on the planetWME: J.U.L.I.A. - Assertion when landing on the planet
Note: See TracTickets for help on using tickets.