Opened 6 years ago

Closed 3 months ago

Last modified 3 months ago

#6526 closed defect (invalid)

WME: 5LD - background goes black on decisions

Reported by: raziel- Owned by: lolbot-iichan
Priority: normal Component: Engine: Wintermute
Keywords: Cc:
Game: Wintermute

Description

ScummVM 1.7.0git (Feb 6 2014 15:42:12)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

On the two instances one has to decide what to do while being locked into the storage room (Kill Mouse / Negotiate) the background goes black with only the speech bubble with "YES / NO" is visible.
So, actually one cannot see what the question is for and as such, if one has never played the game, might get stuck.

I haven't played it on the original interpreter, so i don't know what should happen there, but i doubt it should simply go blank?

Attached is a save right before the negotiate question comes up, simply "use axe on door"

Five Lethal Demons (Windows/English)

Amiga OS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: bugs/6526.

Attachments (1)

5ld-win.000 (101.5 KB ) - added by raziel- 6 years ago.

Download all attachments as: .zip

Change History (11)

by raziel-, 6 years ago

Attachment: 5ld-win.000 added

comment:1 by misterhands, 6 years ago

The background going black is normal and occurs in the original.
As for the missing title in question boxes, I've reported it here:

https://sourceforge.net/p/scummvm/bugs/6501/

comment:2 by somaen, 6 years ago

Component: Engine: Wintermute
Game: Wintermute

comment:3 by somaen, 6 years ago

so, this is a combination of "bug exists in original", and a dupe?

comment:4 by misterhands, 6 years ago

Pretty much, though the screen going black could be by design.

comment:5 by somaen, 5 years ago

Owner: set to somaen

comment:6 by lolbot-iichan, 4 months ago

Resolution: invalid
Status: newpending

I believe is "by design" to avoid showing murders.

Missing title is duplicate of #6501, which is fixed at https://github.com/scummvm/scummvm/pull/1712

comment:7 by raziel-, 3 months ago

Yes, the titles are there now and the game is completable.

Thanks a lot

comment:8 by raziel-, 3 months ago

Owner: changed from somaen to lolbot-iichan
Resolution: invalidfixed
Status: pendingclosed

comment:9 by lolbot-iichan, 3 months ago

Resolution: fixedinvalid

comment:10 by lolbot-iichan, 3 months ago

Summary: WME: 5LD background goes black on decisionsWME: 5LD - background goes black on decisions
Note: See TracTickets for help on using tickets.