Opened 6 years ago

Closed 6 years ago

Last modified 13 months ago

#6494 closed defect (fixed)

TEENAGENT: Yet another unimplemented callback

Reported by: SF/mrugiero Owned by: digitall
Priority: normal Component: Engine: TeenAgent
Keywords: Cc:
Game: TeenAgent

Description

This time built from git current, in the second chapter, next to a squirrel in a tree there is a nut. If you try to examine the nut, you get the unimplemented callback 0x5634.
I provide a savegame to reproduce it.

Ticket imported from: bugs/6494.

Attachments (3)

teenagent.01 (41.3 KB ) - added by SF/mrugiero 6 years ago.
callback0x830b.patch (569 bytes ) - added by SF/mrugiero 6 years ago.
warning.patch (401 bytes ) - added by SF/mrugiero 6 years ago.

Download all attachments as: .zip

Change History (13)

by SF/mrugiero, 6 years ago

Attachment: teenagent.01 added

comment:1 by SF/mrugiero, 6 years ago

Also, may I advise to change the error for the unimplemented cases to a warning? That would be less disruptive.

comment:2 by SF/mrugiero, 6 years ago

Another one, using the chainsaw on the branch, in the back of the mansion.
Callback 0x830b.

by SF/mrugiero, 6 years ago

Attachment: callback0x830b.patch added

comment:3 by SF/mrugiero, 6 years ago

Added a patch for the missing callback 0x830b

by SF/mrugiero, 6 years ago

Attachment: warning.patch added

comment:4 by SF/mrugiero, 6 years ago

Added a patch for substituting the missing callback errors for a warning.

comment:5 by lordhoto, 6 years ago

I think the main issue with a warning is that nearly no user would ever see such a warning because it's only printed in the log and/or on stderr. As a result we wouldn't get bug reports like this.

comment:6 by digitall, 6 years ago

Owner: set to digitall

comment:7 by digitall, 6 years ago

As Lordhoto said, unimplemented callbacks now trigger error() rather than warning() to ensure we get user feedback such as this.

The original hacky decoding for dealing with them was removed in 31cb5ce3f1e970699318e1c7cbfe1ae57804a14c. I had thought I had got all the missing ones, but it appears I missed a few. Will fix these two.

comment:8 by digitall, 6 years ago

Fixed both missing callbacks in commit 4df249b9cec6c9d4ecc0aa8129beb816379d77fa. Closing this bug as fixed.

Mario, please test with the next nightly build / git build and feel free to reopen this if you get any more missing callback errors.

comment:9 by digitall, 6 years ago

Resolution: fixed
Status: newclosed

comment:10 by digitall, 13 months ago

Component: Engine: TeenAgent
Game: TeenAgent
Note: See TracTickets for help on using tickets.