Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#648 closed defect (worksforme)

MI1: crash

Reported by: SF/quitelost Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Monkey Island 1 (shortname: monkey) crashes at the beginning of Part 2 (on the ship). Just after the dialog at the start of the part, scummvm crashes and disappears. Operating system is Windows XP. I have tried the latest daily build. I'm attaching a saved game (called "hanna"). Game crashes just after Guybrush has said "--sigh--".

Ticket imported from: #658199. Ticket imported from: bugs/648.

Attachments (1)

monkey.s01 (38.6 KB ) - added by SF/quitelost 17 years ago.
Save game file

Download all attachments as: .zip

Change History (8)

comment:1 by SF/khalek, 17 years ago

I think your savegame could be a little bit more... attached

by SF/quitelost, 17 years ago

Attachment: monkey.s01 added

Save game file

comment:2 by SF/quitelost, 17 years ago

Think it is now. IE bugging me.

comment:3 by SF/khalek, 17 years ago

works fine here with cvs under linux.. could you paste the last few lines of console output from scummvm before it crashes?

comment:4 by SF/quitelost, 17 years ago

How do I get the debug log to a file? I'm not quick enough to read or snap the text before scummvm dies. . .

comment:5 by SF/quitelost, 17 years ago

Ok, so I got to try it under Linux too. And then easily managed to read the last error line written by scummvm:

Error: Gdi::decompressBitmap: default case 136!

I suppose this means my game is broken? I also ran it with -d10, and have a verbose but long error log, if anyone is interested.

comment:6 by fingolfin, 17 years ago

Works for me. I can only assume that your data files are broken. In any case, as long as we can't reproduce it, we can't help the problem, sorry.

comment:7 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Summary: Monkey crashes.MI1: crash
Note: See TracTickets for help on using tickets.