Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#6464 closed defect (fixed)

SCI: SQ5 - Extra sounds play when opening airlock

Reported by: SF/boneosaurusrex Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Space Quest 5

Description

When opening the airlock (killing yourself) ScummVM plays sound effects that the original doesn't. In addition to the two expected sounds (door opening and D'oh) a loud bang sound repeats three times until the scene ends. This bang sounds like the sound that plays when asteroids hit the ship while in the asteroid field, though I'm not 100% on that. The expected behavior is that only the door-opening and D'oh effects play, at least that's what occurs in the original.

Attached are savegames from ScummVM and Sierra SCI at the airlock.

ScummVM 1.7 latest, Win32
SQ5 1.04 English

Ticket imported from: bugs/6464.

Attachments (2)

sq5.005 (40.4 KB) - added by SF/boneosaurusrex 6 years ago.
SQ5SG.002 (9.4 KB) - added by SF/boneosaurusrex 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by SF/boneosaurusrex

Attachment: sq5.005 added

comment:1 Changed 6 years ago by m-kiewitz

Component: Engine: SCI
Game: Space Quest 5

comment:2 Changed 5 years ago by m-kiewitz

Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed

comment:3 Changed 5 years ago by m-kiewitz

just got fixed by commit d1bab54a4ad9022ecc756acd09fa900f0a311404

was an inaccuracy in our kDoSound(play) implementation. Sierra wasn't able/didn't want to play multiple samples at once. We supported that. The scripts actually want that other sound effect to be played for a few milliseconds. Probably an oversight, that was never noticed because of the limitation.

Note: See TracTickets for help on using tickets.