Opened 5 years ago

Closed 16 months ago

Last modified 4 months ago

#6450 closed defect (wontfix)

SYMBIAN: Mohawk complation fails

Reported by: SF/superzanac Owned by: csnover
Priority: normal Component: Port: Symbian
Keywords: Cc:
Game:

Description

There are two myst.cpp files in two different directories. So in case symbian building system
outputs the object files in the same directory there became clashes
and one object file is lost.
I renamed one in mohawk\myst_stacks to myst_stack.cpp and compilation was fine.
(Thaks to Johannes Schickel for tips)

Ticket imported from: #3615190. Ticket imported from: bugs/6450.

Change History (7)

comment:1 Changed 5 years ago by lordhoto

This is not a bug in Myst, it rather seems that the Symbian build system is not set up properly.

comment:2 Changed 5 years ago by SF/superzanac

Symbian build sustem hasn't any settings for this. It compiles or not out of box.
This issue breaks portability. I did not know what to do while you says about two myst.cpp.

comment:3 Changed 5 years ago by lordhoto

Component: Engine: Toltecs
Game: 3 Skulls of the Toltecs
Summary: MYST have 2 myst.cppSYMBIAN: Mohawk complation fails

comment:4 Changed 5 years ago by lordhoto

Component: Engine: Toltecs
Game: 3 Skulls of the Toltecs

comment:5 Changed 5 years ago by Strangerke

Component: Ports

comment:6 Changed 16 months ago by csnover

Keywords: build removed
Owner: set to csnover
Resolution: wontfix
Status: newclosed

I don’t think there is anything to be done here, since there are many object files with the same names throughout ScummVM source (so this seems unlikely to be a ScummVM problem), and this port seems to have no maintainer. So I am going to close this for now.

comment:7 Changed 4 months ago by digitall

Component: PortsPort: Symbian
Note: See TracTickets for help on using tickets.