Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6441 closed defect (wontfix)

SCI: LB2CD - Saved games aren't saving Speech/Text mode

Reported by: SF/boneosaurusrex Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

When loading a saved game the game's Speech/Text mode always reverts to Speech, even when the game was saved while in Text mode. All other control panel settings are preserved except the Speech/Text mode. Sierra SCI preserves Speech/Text mode.

To reproduce:

1. Go to the control panel and set the Speech/Text mode to Text.
2. Save the game.
3. Load the saved game.
4. Go to the control panel to see that the mode is set back at Speech.

Reproduced in ScummVM 1.6 & 1.7 Nightly build (Oct 29) - Win32
Game version: LB2CD English 1.1

Ticket imported from: #3615160. Ticket imported from: bugs/6441.

Change History (3)

comment:1 by digitall, 6 years ago

Summary: LB2CD: Saved games aren't saving Speech/Text modeSCI: LB2CD - Saved games aren't saving Speech/Text mode

comment:2 by bluegr, 6 years ago

This is a feature for SCI1.1 CD games, not a bug :)

We preserve the speech/subtitle settings that are set through ScummVM's GUI. We can't allow each save game to override them, as this would lead to confusion.

I've pushed a commit (f9bbc2c) that modifies ScummVM's audio and subtitle options when they are changed in game. So now, if you change the mode to "Text", ScummVM's audio options will be synced as well, so this change is kept when loading saved games in the future.

So now, say you got:
- LB2CD set up to use speech
- A saved game A that you saved with "speech"
- A saved game B that you saved with "text"

Loading either saved game will leave the audio options to "speech".

Now, if you change your game options to "Text", loading either saved game will leave the audio options to "Text".

Modifying the game speech/subtitle settings when a saved game is loaded is a bad idea, and will be confusing for no reason. You can just toggle the option you want, and it'll remain stable even after loading a game, until you change it again.

Closing as "won't fix".

comment:3 by bluegr, 6 years ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.