Opened 6 years ago

Closed 6 years ago

#6440 closed defect (fixed)

SCI: LB2CD - Control Panel icon disabled in Speakeasy

Reported by: SF/boneosaurusrex Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

Sometimes upon entering the speakeasy the control panel icon is disabled, which it shouldn't be. Sometimes this persists even after leaving the speakeasy. I saw this sporadically in other rooms, but the speakeasy was the most reproducible. So far I've only seen this in the CD version, I haven't been able to reproduce it with the floppy version.

Screenshots and save game (CD version) attached. To reproduce with save game:

1. Enter speakeasy
2. Check icon menu, control panel will be disabled
3. Exit speakeasy back to street
4. Check icon menu, control panel will still be disabled

Reproduced in ScummVM 1.6 & 1.7 Nightly build (Oct 29) - Win32
Game version: LB2CD English 1.0

Ticket imported from: #3615159. Ticket imported from: bugs/6440.

Attachments (3)

laurabow2-cd.000 (42.2 KB ) - added by SF/boneosaurusrex 6 years ago.
Save game outside speakeasy, upon entering control panel icon will be disabled
1_inside_speakeasy.jpg (51.7 KB ) - added by SF/boneosaurusrex 6 years ago.
Upon entering the speakeasy
2_outside_speakeasy.jpg (44.4 KB ) - added by SF/boneosaurusrex 6 years ago.
Upon exiting the speakeasy (still disabled)

Download all attachments as: .zip

Change History (10)

by SF/boneosaurusrex, 6 years ago

Attachment: laurabow2-cd.000 added

Save game outside speakeasy, upon entering control panel icon will be disabled

by SF/boneosaurusrex, 6 years ago

Attachment: 1_inside_speakeasy.jpg added

Upon entering the speakeasy

by SF/boneosaurusrex, 6 years ago

Attachment: 2_outside_speakeasy.jpg added

Upon exiting the speakeasy (still disabled)

comment:1 by digitall, 6 years ago

Summary: LB2CD: Control Panel icon disabled in SpeakeasySCI: LB2CD - Control Panel icon disabled in Speakeasy

comment:2 by SF/boneosaurusrex, 6 years ago

After more testing I can now confirm that this is a bug in the original game and only affects the CD version. ScummVM is behaving just like the original.

Yvette's office and Olympia's office consistently disable the control panel when entering them and it often sticks around when going into the next room such as Carrington's office. Switching the screen to notebook view by clicking the inventory hand icon on the notebook and then exiting notebook view makes the control panel icon come back in all of these cases except inside the speakeasy where the control panel remains disabled even after viewing the notebook.

This also prevents keys such as F5 and F7 from functioning since the game thinks it's in the no-saves-or-loads-allowed mode.

comment:3 by m-kiewitz, 6 years ago

Hi,

Would you mind testing this out through the whole game?

I just made it possible to have text + audio at the same time for the CD version, which also needs a bit of testing. This issue here is a bit complicated and I had to patch something, that's executed for every room in the whole game.

comment:4 by m-kiewitz, 6 years ago

Keywords: original added
Owner: set to m-kiewitz
Resolution: fixed

comment:5 by SF/boneosaurusrex, 6 years ago

After quite a bit of testing I haven't found any side effects from the control panel fix, great job! The speech + text patch is also working perfectly, I haven't found any problems and I think it's now my favorite mode.

Now that their bug is fixed it's clear which rooms they intentionally disabled the control panel in. It's crazy how many of them there are, I was raised on the floppy version so I'm really confused as to what drove them to sporadically sabotage saving and loading in the later "advanced" version. It smells like a last minute workaround for something but since the notebook trick defeats it and I'm not seeing any problems with control panel actions in the forbidden rooms... I just have no idea what they were going for.

In case this helps with further testing, these are the rooms I've found that the CD version disables the control panel in where the floppy doesn't:

Inside Speakeasy (the one room where the notebook doesn't enable control panel)
West Egyptian wing
Mastodon room
Old Masters Gallery
Olympia's
Yvette's
Carrington's
Ernie's (when he's in the room, otherwise inconsistent)
Mummy storage room

Thanks again for the great work!

comment:6 by m-kiewitz, 6 years ago

Thank you.

comment:7 by m-kiewitz, 6 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.