Opened 17 years ago

Closed 17 years ago

Last modified 7 months ago

#642 closed defect (invalid)

ALL: Mac midi drivers not working anymor

Reported by: fingolfin Owned by: SF/jamieson630
Priority: high Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

Since today's imuse changes, CoreAudio & Quicktime midi
drivers on OS X don't work anymore. They did work just
fine yesterday. The Adlib does seem to work OK, though.

Ticket imported from: #656018. Ticket imported from: bugs/642.

Change History (11)

comment:1 Changed 17 years ago by fingolfin

I have to correct myself, this wasn't latest CVS. Latest CVS
doesn't even compile here.

comment:2 Changed 17 years ago by fingolfin

OK it compiles fine again here, but the problem still
persists. What makes it annoying that stuff that syncs with
iMuse doesn't work, e.g. the opening credits in MI2 don't
start playing.

comment:3 Changed 17 years ago by SF/jamieson630

In what way do they "not work"? Does music simply not
play, but without any warnings/errors? Or are you
getting "Cannot find sound" errors to boot?

Also, are you playing with the Mac-version resources, or
some other version?

No other port is reporting any problems whatsoever -- the
latest architectural changes are working under -ewindws
and -eseq. Furthermore, none of the architectural changes
directly involved the Mac-specific drivers; the changes are
in the common areas and would theoretically break all
drivers at once.

Before I go digging around for a problem potentially in code
that's not even included in my own builds, could you verify
for me that 0.3.0b is still playing music fine on your box?
Just so we can isolate the problem to CVS ScummVM, and
not to some other box-specific problem.... Thanks.

comment:4 Changed 17 years ago by fingolfin

1) "not work" means that music doesn't play (with CoreAudio
and QuickTime drivers), it means that I can't hear anything,
and as was stated in my report, that syncing to iMuse
effects doesn't take place (i.e. the MI2 intro just hangs
forever, because it is cued to certain iMuse events I assume).

2) The "Mac-Version" resources for music fall into two
catgories: not supported by us at all, or MIDI. So I don't
see how this is relevant :-) But the problem occurs with PC
versions just as well as if with Mac versions.

3) Every backend is different, so it is very well possible
for a change in a common area to only change 1-2 ports. E.g.
the Mac backend is big endian, the ones you list aren't. And
windows/seq hardly are an exhaustive list, what about ALSA
and morphos I wonder, or runing it on Linux/PPC etc. :-)

4) Yes it works with 0.3.0b, and also with CVS from before
your changes. So I don't think it's my machine being broken.

5) I just tried Simon and see that it doesn't play music
anymore, either. So it's probably not the changes to imuse,
but rather some of the changes in sound/.

comment:5 Changed 17 years ago by SF/jamieson630

Priority: normalhigh

comment:6 Changed 17 years ago by SF/jamieson630

Kirben has also confirmed this in mingw builds. That's
something I can at least test with a little more. Hopefully we
can put this to bed quickly now.

comment:7 Changed 17 years ago by SF/jamieson630

Okay, music problem in mingw vaporized into thin air after a
few tests, so that's out. However, another problem that came
up was an SDL segfault anytime the user tries to F5 into the
GUI. The crash was still present even after removing iMuse
from the system entirely. Whatever is causing that does not
sem to be iMuse-related.

Fingolfin, can you tell me if you have a problem with SDL
segfaults when trying to get into the GUI on Mac? Like the
music problem, this bug does not seem to be manifesting
itself on VC++ or Linux gcc builds.

comment:8 Changed 17 years ago by fingolfin

Music still not working here.

No crash upon F5 here. I don't see how those two could be
related, anyway. If the F5 crash is reproducible, a bug
report including backtrace would be highly appreciated.

comment:9 Changed 17 years ago by SF/jamieson630

Okay, music problem was apparently a phantom related to
dependency tracking failures in the two compilers reporting
problems. Closing.

comment:10 Changed 17 years ago by SF/jamieson630

Resolution: invalid
Status: newclosed

comment:11 Changed 7 months ago by digitall

Component: Port: Mac OS X
Note: See TracTickets for help on using tickets.