Opened 6 years ago

Closed 2 months ago

#6419 closed defect (fixed)

SCUMM: Android - Color Mode Unsupported for bluesabctime

Reported by: (none) Owned by: ccawley2011
Priority: normal Component: Port: Android
Keywords: Cc:
Game: Blue's ABC Time Activities

Description

When attempting to launch this game under android I receive a "color mode not supported". Changing the graphics render mode doesn't change anything. Is there a debug build I can run which will give you actual logs?

Language: English
Version: CD dump (this same dump works with the 1.6.0 Wii build)
ScummVM: Android Version 1.6.0 & the latest nightly (1.7.0 git2211-gf35298f - Oct 6 2013)
Android Version: 4.2.2

Ticket imported from: #3615075. Ticket imported from: bugs/6419.

Change History (6)

comment:1 by digitall, 6 years ago

Summary: Android - Color Mode Not SupportedSCUMM: Android - Color Mode Unsupported for bluesabctime

comment:2 by digitall, 6 years ago

Hunter: The simple answer is No. You will have to compile your own build to add debugging output to narrow down why this is occuring.

At an educated guess from the error message and game, I suspect that the scumm engine for this game is failing in Common::Error ScummEngine::init() returning a kUnsupportedColorMode ... but this occurs when the backend can't provide the required color depth for the game, so the problem is probably associated with the Android backend GFX code and possibly the OpenGL ES implementation on your device which may not provide a full set of color depths...

I am no expert on Android, but the following is a set of HOWTOs and some pointers if you want to try to debug this yourself or at least provide more information... otherwise you will have to wait for our rather busy IRL Android developers to take a look... which may take some time:
http://wiki.scummvm.org/index.php/Compiling_ScummVM
http://wiki.scummvm.org/index.php/Compiling_ScummVM/Android
http://wiki.scummvm.org/index.php/Debugging_ScummVM#Android
https://github.com/scummvm/scummvm/blob/master/engines/scumm/scumm.cpp#L1165
https://github.com/scummvm/scummvm/blob/master/backends/platform/android/gfx.cpp#L93

I hope this helps...

comment:3 by wjp, 6 years ago

There's no need for more debugging output. HE games such as this one currently require a 555 mode, which doesn't work in the android backend.

We're still figuring out if we should fix this in the engine or in the backend, but there's not much you can do about it right now.

comment:4 by digitall, 13 months ago

Component: Engine: SCUMMPort: Android

comment:5 by ccawley2011, 3 months ago

Owner: set to ccawley2011
Resolution: fixed
Status: newpending

comment:6 by ccawley2011, 2 months ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.