Opened 5 years ago

Last modified 4 years ago

#6409 new defect

AGOS: Elvira 2 Power Points stop regenerating in Studio 3

Reported by: SF/jeedras Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Elvira 2

Description

Scummvm 1.6
Language: English
Version: Amiga

I can't really put my finger on when this starts happening but somewhere in studio 3 (catacombs) power points stop to regenerate. P.P is supposed to raise every half a minute or so but they don't at all when I get to catacombs.

Ticket imported from: #3615016. Ticket imported from: bugs/6409.

Attachments (4)

elvira2.034 (6.0 KB) - added by SF/jeedras 5 years ago.
Game save
elvira2.037 (6.0 KB) - added by SF/jeedras 5 years ago.
Here PP's regenerate
elvira2.014 (5.9 KB) - added by SF/stephan92 4 years ago.
elvira2.015 (5.9 KB) - added by SF/stephan92 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by SF/jeedras

Attachment: elvira2.034 added

Game save

comment:1 Changed 5 years ago by digitall

Summary: Elvira 2 gameplay issue/ P.P Don't regenerateAGOS: Elvira 2 Power Points stop regenerating in Studio 3

comment:2 Changed 5 years ago by digitall

jeedras: I assume the attached savegame is before the bug has started occurring? If not, could you attach a savegame before you enter Studio 3 or rather while the Power Points are still regenerating. This will help the AGOS engine developers to track down the cause of this.

Also, could you try the latest development snapshot from http://buildbot.scummvm.org/builds.html to see if the bug is occurring there (from a saegame where it is not occurring play forward... and see) and ditto for a few earlier versions ie. v1.0.0 to eliminate this as a recent regression...

I suspect that this is probably a long standing bug / bug in the original scripts, but it would need you to play this via the original interpreter under DOSBox to confirm this...

If you can provide this information, it will help the developers track down this bug quickly and thus get it fixed...

Changed 5 years ago by SF/jeedras

Attachment: elvira2.037 added

Here PP's regenerate

comment:3 Changed 5 years ago by SF/jeedras

I added a savegame before entering catacombs when P.Ps still regenerate. They weren't regenerating in all my studio 3 saves and a little bit earlier. I'm currently dungeoncrawling studio 3 again and so far P.Ps regenerate. Maybe this bug is rare? For sure it is difficult to notice when power points stop to grow.

comment:4 Changed 5 years ago by digitall

Owner: set to Kirben

comment:5 Changed 5 years ago by digitall

It is quite possible that this bug is tricky to replicate/trigger, but if you have attached a savegame with the "normal" game state and one with a game state where the PP are failing to regenerate, that should be sufficient for the AGOS engine developers to investigate.

Assigning to AGOS maintainer for visibility...

Changed 4 years ago by SF/stephan92

Attachment: elvira2.015 added

comment:6 Changed 4 years ago by SF/stephan92

SCUMMVM version 1.7.0 on PC plateform

Hi.
I confirm the issue. I have the similar phenomenom. What I have noticed:
Studio 2 and then Studio 1 exploration : no problem, the PP point increase correctly until the boss of Studio 1 is killed.
After finishiing the Studio 1 exploration (get the tomahawk) the PP point do not increase anymore.
Enclosed Save game :
elvira2.014 : PP increase correctly
elvira2.015 : no more modification on PP.
Between the two save games : kill the Boss of the Studio 1 and going back to the Studio 2.

Another strange point : As soon a courage and BrainBoost Spell have been activated, it do not stop. Good point to help to finish the game but I assume it's not normal too.
Tested with the English and the French version of the game.

Thank you

comment:7 Changed 4 years ago by Kirben

Could you please check whether this bug occurs in the original Amiga version too, as I suspect this is another script bug in the original.

To use a saved game from ScummVM in original Amiga version:
Add .z extension to filename, and unpack the saved game.
Use a hex or text editor to remove the first 8 bytes.
Rename the saved game file to expected style (i.e. studio.SAV).

Note: See TracTickets for help on using tickets.