Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6402 closed defect (fixed)

SCI: Camelot - voyeur crash in Jerusalem

Reported by: misterhands Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Conquests of Camelot

Description

Latest daily Win 64 build
CoC DOS

Load the savegame.
Type LOOK WINDOW.
Arthur walks to the window and after a few seconds the game throws and error:
lookupSelector(): Attempt to send to non-object or invalid script. Address was 0000:0000!

If you simply walk to the window the game doesn't crash, you just die violently if you linger a little too long :-)

Ticket imported from: #3614969. Ticket imported from: bugs/6402.

Attachments (2)

camelot.036 (29.7 KB ) - added by misterhands 6 years ago.
conquestsOfCamelotOops.jpg (94.0 KB ) - added by m-kiewitz 6 years ago.
Conquests Of Camelot - Oops message of original Sierra interpreter

Download all attachments as: .zip

Change History (9)

by misterhands, 6 years ago

Attachment: camelot.036 added

comment:1 by bluegr, 6 years ago

This is quite hard to reproduce reliably. It looks as if the offending actor is the merchant's daughter. If you leave the message boxes long enough, when they're closed, the scripts will destroy the actor before making her walk off-screen. This looks like a script bug, and it's definitely time related - it doesn't happen if you just read the message boxes and close them normally (i.e. without waiting forever)

comment:2 by misterhands, 6 years ago

For me the girl doesn't walk off-screen but she disappears after a few moments, even if you do nothing, as if she is done with her shower. It's possible to reset the shower sequence by walking south to the next screen and then going back. This way the shower lasts longer and the girl does not get in the way of the error, so to speak!

By doing so, I can get that error quite consistently and the timing of letting/skipping the msg boxes appear to be irrelevant to this bug.

Hope this helps!

comment:3 by m-kiewitz, 6 years ago

I just managed to get an "Oops!" error, when trying the same in Sierra SCI. Which means it's actually a script bug. Normally you are supposed to get killed by the father of the girl. But when ego walks to the window instead of walking there manually, the father isn't loaded into memory. I attached a screenshot showing the error message in Sierra SCI.

Will try to work out a script patch.

comment:4 by m-kiewitz, 6 years ago

Keywords: original added; script removed
Owner: set to m-kiewitz

by m-kiewitz, 6 years ago

Attachment: conquestsOfCamelotOops.jpg added

Conquests Of Camelot - Oops message of original Sierra interpreter

comment:5 by m-kiewitz, 6 years ago

fixed today by commit bac818ccb74d8d608189dc5959e3472c7b2358d3

script patch to fix Sierra bug

comment:6 by m-kiewitz, 6 years ago

Status: newclosed

comment:7 by m-kiewitz, 6 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.