Opened 6 years ago

Closed 6 years ago

Last modified 11 months ago

#6386 closed defect (invalid)

PSP: Various game crashes on FW 6.60.

Reported by: SF/jonnysutt Owned by:
Priority: normal Component: Port: PSP
Keywords: Cc:
Game:

Description

I'm trying to play all my SCUMMVM games (on version 1.4.1) on my PSP cfw 6.60 Pro B10 perminant. Most games work fine however I am having problems with a number of games (not sure if they are related to the 6.60 firmware or the SCUMMVM version) and I would be grateful if anyone could help me with each.

Broken Sword - Blank screen as it starts

Broken Sword 2 - Crashes as virgin ad begins

The 7th Guest - Blank screen as it starts

Toonstruck - Blank screen as it starts

Beneath a Steel Sky - Starts and crashes as the yellow faced man appears and 2 lines of dialogue are heard.

Woodruff - Crashes during dinosaur cutscene

Touche - Choppy cutscene at the beginning and then crashes

I know there are a few there but I thought if I gave you an insight into all of the problems perhaps you would know what the root of the issue is. I'm guessing the first 4 games problem might be linked to memory? Thank you.

Ticket imported from: #3614875. Ticket imported from: bugs/6386.

Change History (18)

comment:1 by SF/jonnysutt, 6 years ago

Priority: normalhigh

comment:2 by DrMcCoy, 6 years ago

Priority: highnormal

comment:3 by SF/jonnysutt, 6 years ago

Priority: normalhigh

comment:4 by DrMcCoy, 6 years ago

Please stop raising the priority. It's for us devs to rate the priority according to our knowledge and plans, and not according to what some users may think is important.

comment:5 by DrMcCoy, 6 years ago

Priority: highnormal

comment:6 by SF/jonnysutt, 6 years ago

sorry, pretty new to this website

comment:7 by digitall, 6 years ago

Summary: PSP cfw 6.60 IssuePSP: Various game crashes on FW 6.60.

comment:8 by digitall, 6 years ago

jonnysutt: Apologies for DrMcCoy's directness! :) But he is correct, please don't fiddle with the priorities as they are used to rate bugs during release phase.

The main issue I can see immediately is that you are using ScummVM v1.4.1 which is very outdated. Unfortunately the PSP porter has not provided any builds for the newer versions.

In the interim please try using the stable build from here, which is an automatically generated v1.6.0 build:
http://buildbot.scummvm.org/builds.html

If that still fails, then I would suggest trying the v1.7.0git development build also listed on that page.

Further help on using the PSP builds can be found here:
http://wiki.scummvm.org/index.php/PlayStation_Portable

However, the lack of release may be due to problems with the PSP binaries related to plugins on MIPS. Please search for other PSP bugs for background on this...

Let us know how you get on.

comment:9 by SF/jonnysutt, 6 years ago

Sorry again about the priority rating, what am I like? Thank you for your support, after trying the v1.7.0git build I have Toonstruck working which is great! I've given up on the 2 broken sword games and I am playing them as psx files now. That only leaves me with 4 more, Touche (which plays but the image is really distorted and choppy), Woodruff (which still stops on the opening cutscene), Beneath a steel sky (which I skip the intro scene to make work, however the image shown for the actual game is terribly distorted and no background is visable just the character) and 7th guest (it started the other day as I launched the v1.7.0git through HBL, but again the image was distorted and finally froze). Could I ask, does launching SCUMMVM through HBL make a difference to the running of games?

comment:10 by digitall, 6 years ago

jonnysutt: I am afraid that I can only provide general help and bug triage. I am not the PSP maintainer, nor do I own the hardware, so I don't really know. The only issue with HBL that I am aware of is that it likely leaves less memory for applications compared to a rooted device, so this may be part of the issue... though the rest could be related to the outstanding PSP issues or to issues with Graphics surface depths for output.

Note that we generally dislike this kind of compound bug as it tends to be very hard to close out, so in future it is better to have a very specific bug and report these issues separately.

I can only say that until the PSP gets an official release again, you can read that as the port being unmaintained or significantly buggy, hence these kind of issues. Sorry that I can't provide further help.

comment:11 by SF/nitrus, 6 years ago

johnysutt: I've tried the latest Development Build both downloaded from buildbot, and compiled by myself, on a PSP 2000, on both 6.60 ME-1.8 CFW and on the 6.60 OFW (by doing a hard reset and holding L+R+Start+Select+Home while booting up). I've tried it by running it independently and with the half byte loader (while on OFW) with Broken Sword 1 and Beneath a Steel Sky. Both worked perfectly. Might I offer the following suggestions:
- If you're using Linux, try emptying the trash can before putting in a new version of ScummVM.
- If you're running any kind of external plugins, for either VSH or GAME, try disabling them from either the XMB or the recovery menu, to free up some memory.
P.S.: Broken Sword 1 's intro actually starts with a 10-15 seconds of black screen while George is talking, then shows the Revolution logo, the Virgin logo, and continues to play the intro movie as usual.

comment:12 by SF/nitrus, 6 years ago

I also tested Broken Sword 2 (with and without HBL, on OFW and CFW), some stuttering/choppiness occurs during both the Virgin logo and the game's cutscenes, but I was able to both watch through them, or skip them, and I ended up playing the game, which works well (no stuttering).
I can test it out with Toonstruck if need be, but not with the other three, as I do not own them, and see no way of acquiring them in the immediate future.
I can only repeat what I've said below, and perhaps add that you should check for proper file copying and renaming according to http://wiki.scummvm.org/index.php/Datafiles , especially if you own Playstation versions of some of the games.
Also, if you could fill in on:
- Which PSP iteration have you got? 1000/2000/Vita...?
- Is your firmware CFW or LCFW?
- Have you tried running ScummVM without HBL? (This should be possible as the firmware is custom.)

Note: I've also tested ScummVM (not with these games specifically) on the older 5.00 M33-6 CFW, and had excellent performance. Currently I'm using the CFW I mentioned below. As a final step I'd try a fresh format on the MemStick, and if it doesn't work, I'd write it off as a Firmware flaw, as I've seen a "Buffer Overflow Fix" for the Pro B-10 floating around the web.

comment:13 by digitall, 6 years ago

Resolution: invalid
Status: newpending

comment:14 by digitall, 6 years ago

jonnysutt: As Nitrus has confirmed that this is likely to be an issue in your firmware, or the trash being present on the memory card, then I am inclined to close this bug as invalid...

I will move this to pending (response from user) for now, until you confirm that you have tried the various fixes suggested by Nitrus or can produce a bug replication case in BASS or a similar freeware game/demo, which Nitrus can replicate.

If you don't respond within 14 days, the bug will be closed automatically as per all pending bugs.

comment:15 by Strangerke, 6 years ago

Component: --Unset--Ports

comment:16 by digitall, 6 years ago

As the original bug submitter is unresponsive and this is likely fixed for him, am now closing as invalid.

comment:17 by digitall, 6 years ago

Status: pendingclosed

comment:18 by digitall, 11 months ago

Component: PortsPort: PSP
Note: See TracTickets for help on using tickets.