Opened 6 years ago

Closed 18 months ago

#6378 closed defect (fixed)

TUCKER: Missing Water Effect in Part 2 Submarine Scene

Reported by: (none) Owned by: sev-
Priority: normal Component: Engine: Tucker
Keywords: Cc:
Game: Bud Tucker

Description

In part two of the game, where the big submarine is, in Dosbox you will see that the water has a glow or shiny effect. In ScummVM there isn't any effect, so the water is completely static.

Savegames attached from Dosbox and ScummVM

Ticket imported from: #3614696. Ticket imported from: bugs/6378.

Attachments (2)

Dosbox_savegame_good_water_glow.zip (636 bytes) - added by SF/*anonymous 6 years ago.
Dosbox savegame with the shiny water effect
ScummVM_savegame_water_glow_bug.zip (483 bytes) - added by SF/*anonymous 6 years ago.
ScummVM savegame without any shiny water effect at all (static water)

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by SF/*anonymous

Dosbox savegame with the shiny water effect

Changed 6 years ago by SF/*anonymous

ScummVM savegame without any shiny water effect at all (static water)

comment:1 Changed 6 years ago by digitall

Confirmed by comparing DOSBox and ScummVM with attached savegames.

There is some kind of palette rotation or similar effect giving the water effect.

In the ScummVM Tucker engine, this occurs for a fraction of a second after loading then stops. I suspect that a script which should loop forever in this scene is ending instead... This may be due to a mistake in the interpretation of one of the opcodes..

comment:2 Changed 6 years ago by digitall

Summary: TUCKER: There isn't any water glow effectTUCKER: Missing Water Effect in Part 2 Submarine Scene

comment:3 Changed 18 months ago by bonki

Potential fix in PR-1117.

comment:4 Changed 18 months ago by bonki

Actually, the code is there and if you look closely you can see the palette actually shifting. The changes are subtle because the palette seems to be "wrong", but shifting it two bits to brighten things up seems to fix everything.

comment:5 Changed 18 months ago by sev-

Owner: set to sev-
Resolution: fixed
Status: newclosed

Fixed by PR-1117

Note: See TracTickets for help on using tickets.