Opened 17 years ago

Closed 17 years ago

Last modified 10 years ago

#637 closed defect (worksforme)

LOOMCD: Hot pink distaff

Reported by: SF/dfabulich Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

When you take the distaff and walk outside, the distaff
is the wrong color. (How stylish! But I prefer the
traditional mahogany.) I decided to go check for
regressions in this game after finding another palette
regression in Zak256; I'm sure I could find more if I
searched hard enough. Attaching saved game and screen
shot.

I'm using ScummVM 0.3.0b, Built on Dec 6 2002 19:31:17
on Win2K.

Ticket imported from: #655126. Ticket imported from: bugs/637.

Attachments (2)

loompal.png (95.3 KB ) - added by SF/dfabulich 17 years ago.
Screenshot of bug
loomcd.s01 (42.2 KB ) - added by SF/dfabulich 17 years ago.
Saved game at this exact spot

Download all attachments as: .zip

Change History (8)

by SF/dfabulich, 17 years ago

Attachment: loompal.png added

Screenshot of bug

by SF/dfabulich, 17 years ago

Attachment: loomcd.s01 added

Saved game at this exact spot

comment:1 by eriktorbjorn, 17 years ago

Could you try this with a more recent CVS snapshot. There
was a change made to o5_roomOps() recently which hopefully
fixed this. It may have re-introduced problems in Zak256
though, but I don't have that game so I can't test.

comment:2 by fingolfin, 17 years ago

Resolution: worksforme
Status: newclosed

comment:3 by fingolfin, 17 years ago

Works for me with latest CVS.

comment:4 by SF/khalek, 16 years ago

Before I try to fix a similiar problem in loomtowns, I don't
suppose someone could give me some idea as to why this was
happening in loomcd?

comment:5 by eriktorbjorn, 16 years ago

I don't remember exactly, but I think it had to do with
whether an opcode should copy one palette entry to another
(so you would get the same colour twice in the palette), or
simply remap it with the "shadow palette" (leaving the
original palette unchanged).

I may have mixed things up though.

comment:6 by Kirben, 10 years ago

Owner: set to fingolfin
Note: See TracTickets for help on using tickets.