Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6351 closed defect (duplicate)

SCUMM: "Game Paused" label is not properly displayed

Reported by: SF/greencis Owned by: criezy
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

WinXP 32bit, ScummVM 1.7.0git540-g49ec202 (Jun 15 2013 07:44:11) Android 2.3.6, ScummVM 1.7.0git540-g49ec202 (Jun 15 2013 06:13:14)

In Full Throttle and Sam and Max Hit the Road (and probably in other SCUMM games, I've tested only these two), if you press Space key, game pauses and a label "Game Paused. Press SPACE to Continue." is shown. Trouble is, there are unknown charachters instead of letters in the label. Of course, the label is unreadable. You can see it on attached screenshots. But in Freddi Fish 1-4 and Water Worries (and probably in other SCUMM games, I've tested only these five), it is shown correctly and the label is readable. Tested on Belarusian, English and Russian GUI languages.

Ticket imported from: #3614505. Ticket imported from: bugs/6351.

Attachments (3)

FT_Ru.PNG (68.1 KB ) - added by SF/greencis 7 years ago.
Full Throttle paused
Sam_n_Max_En.PNG (45.0 KB ) - added by SF/greencis 7 years ago.
Sam and Max Hit the Road paused
Sam_n_Max_Android_En.png (44.1 KB ) - added by SF/greencis 7 years ago.
Sam and Max Hit the Road paused on Android

Download all attachments as: .zip

Change History (8)

by SF/greencis, 7 years ago

Attachment: FT_Ru.PNG added

Full Throttle paused

by SF/greencis, 7 years ago

Attachment: Sam_n_Max_En.PNG added

Sam and Max Hit the Road paused

by SF/greencis, 7 years ago

Attachment: Sam_n_Max_Android_En.png added

Sam and Max Hit the Road paused on Android

comment:1 by digitall, 7 years ago

I have just tried this with the latest git master and I can't replicate this with my English versions of Full Throttle...

Checking the code, these strings are output from the code in the engine dialog file: https://github.com/scummvm/scummvm/blob/master/engines/scumm/dialogs.cpp#L174

The SCUMM engine running in version 5 and below is localised with the translation.dat translating these strings, but running in version 6, 7 and 8+, these strings are hardcoded to English only... which may explain the observed issue. Since FT, The Dig use these versions: http://wiki.scummvm.org/index.php/SCUMM/Versions

Assigning to criezy to do further investigation...

comment:2 by digitall, 7 years ago

Owner: set to criezy

comment:3 by digitall, 7 years ago

Summary: GUI: SCUMM: "Game Paused" label is not properly displayedSCUMM: "Game Paused" label is not properly displayed

comment:4 by bluegr, 7 years ago

Duplicate of bug 1946611: https://sourceforge.net/tracker/?func=detail&aid=1946611&group_id=37116&atid=418820 Closing

comment:5 by bluegr, 7 years ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.