Opened 7 years ago

Closed 7 years ago

#6346 closed defect (fixed)

SCI: LSL2- No points for wearing parachute

Reported by: SF/eoakford Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Leisure Suit Larry 2

Description

According to the LSL2 hintbook, wearing the parachute at the airplane's smoking section is supposed to give you 4 points. However, in ScummVM, no points are given for this action.

ScummVM version: 1.7.0git505-g4401f40 Language: English Game version: 1.002.000 (from the 2006 LSL collection) Platform: Linux

Ticket imported from: #3614419. Ticket imported from: bugs/6346.

Attachments (2)

lsl2parachute_points.tar.gz (22.8 KB ) - added by SF/eoakford 7 years ago.
Savegame from original interpreter.
lsl2.020 (32.9 KB ) - added by SF/eoakford 7 years ago.
Savegame just before buying the parachute.

Download all attachments as: .zip

Change History (23)

comment:1 by SF/eoakford, 7 years ago

Summary: No points for wearing parachuteLSL2: No points for wearing parachute

comment:2 by digitall, 7 years ago

Hmm... That is listed as 4 points for wearing the parachute here: http://sierrahelp.com/Misc/PointLists/LSL2Points.html

Will check.

comment:3 by digitall, 7 years ago

Well, I can replicate this from the savegame with my version from LSL Collection i.e. "(wear/put on) parachute" does not give you any points.

eoakford: Could you test this with the original DOS Interpreter using DOSBox please, and see if this is a regression from the original. Either way, could you attach the original interpreter savegame to this bug for reference.

by SF/eoakford, 7 years ago

Attachment: lsl2parachute_points.tar.gz added

Savegame from original interpreter.

comment:4 by SF/eoakford, 7 years ago

A savegame from the original interpreter has been uploaded. Wearing the parachute gives the points here, so this is indeed a ScummVM bug.

comment:5 by digitall, 7 years ago

Summary: LSL2: No points for wearing parachuteSCI: LSL2- No points for wearing parachute

comment:6 by digitall, 7 years ago

eoakford: Thank you for confirming this and adding the savegame. It may take a little time for a SCI engine developer to investigate this bug and attempt a fix, so please be patient and standby...

comment:7 by bluegr, 7 years ago

In that savegame, it looks as if you've already worn the parachute once - IIRC, you can wear it in any room inside the plane, and you'll get the points. Wearing it a second time won't give you any more points.

comment:8 by bluegr, 7 years ago

Owner: set to bluegr
Resolution: worksforme
Status: newpending

comment:9 by bluegr, 7 years ago

This tracker item is pending response by the submitter; we cannot continue processing it before that happens. As a consequence, its status has been set to "Pending". It will automatically revert to "Open" once a new comment is made to this item. If no response is made within 14 days, it will automatically be closed.

Thank you.

comment:10 by SF/eoakford, 7 years ago

Nope, Larry isn't already wearing the parachute in the save. Jumping out of the plane and trying to use the parachute will say so.

comment:11 by digitall, 7 years ago

eoakford: No... I think you have misunderstood thebluegr's point i.e. You are not getting points for wearing the parachute because you have already worn it once before and then removed it. To phrase it another way, you only get the points the first time you wear the parachute. If you truely haven't worn it earlier then this is a script bug... but we would need a savegame before you have picked up the parachute to allow replication of this from pickup to exit of plane, with no points increase.

by SF/eoakford, 7 years ago

Attachment: lsl2.020 added

Savegame just before buying the parachute.

comment:12 by SF/eoakford, 7 years ago

Okay, I've replaced the ScummVM save with one just before buying the parachute. Furthermore, you CAN'T wear it before entering the plane.

comment:13 by SF/eoakford, 7 years ago

Status: pendingnew

comment:14 by digitall, 7 years ago

eoakford: Thanks for this. Replicated the described bug. To do so, Load the attached savegame, then "Buy Insurance" (This gives you the parachute (3 points), then proceed North up the gangway. After the cutscene on the travelator, walk to the left of checkin desk then "Get Pamphlet" (11 points), then "Show Ticket" at desk (3 points). Walk into plane. Wait until seated and take off complete and Ken is being a pain, then "Give Pamphlet" (8 points), then "Get Airsick Bag" (5 points), then "Stand" and then walk to the back of the plane. Here you can then "Wear Parachute"... which should give 4 points, but actually none are given. See http://sierrahelp.com/Misc/PointLists/LSL2Points.html for reference. It does look like around 7 points were missed earlier in the game... but not sure why this would be happening.

Would need a SCI developer to investigate.

comment:15 by digitall, 7 years ago

To be clear when the savegame loads, you have 290 points... and after the actions below, this is increased to 320... but wearing the parachute fails to increment this by 4 points to 324.

comment:16 by digitall, 7 years ago

Ah, based on the points list and a failure to do "insert pin" on door, this is because in the screen to the left of the insurance you need to "Buy Food" and "Get Pin" (from food) to get the booby pin for this... which is the missing 7 points.

comment:17 by digitall, 7 years ago

*cough* Errata for previous comment is _Bobby_ Pin and the food counter is at the bottom left of the screen with the insurance machine :)

Replayed getting pin and I can still confirm that wearing the parachute does fail to increment the points by 4... So this bug is fully confirmed.

comment:18 by digitall, 7 years ago

Resolution: worksforme

comment:19 by m-kiewitz, 7 years ago

Owner: changed from bluegr to m-kiewitz
Resolution: fixed

comment:20 by m-kiewitz, 7 years ago

fixed today by #3614419

was a sierra script bug, which just happened to work in SSCI

comment:21 by m-kiewitz, 7 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.