Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#6335 closed defect (fixed)

PSP: DISCWORLD: In-game cursor goes past screen

Reported by: SF/nitrus Owned by: bluegr
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

When you press select on the PSP, and the virtual keyboard is on, if you move the analog, the in-game cursor is allowed to move past the screen boundary, and it's very easy to lose it since it moves with an incremental speed. The cursor from the ScummVM's GUI works fine. This does not happen with other games like Simon the Sorcerer for example, where the in-game cursor is locked while the virtual keyboard is active.

IMHO something like "if the game is Discworld and platform is PSP and the Virtual keyboard is ON, lock the in-game cursor at it's current location" should work.

Ticket imported from: #3613765. Ticket imported from: bugs/6335.

Change History (8)

comment:1 by SF/nitrus, 8 years ago

Forgot to mention, this does not happen when you're playing with the virtual keyboard off. When it's off, the cursor Is hitting the screen's boundaries as it should.

comment:2 by SF/nitrus, 8 years ago

On further inspection I've noticed that the Analog does translate into Dpad, and it provides (presumably) ascii output. For example, on every game's Save Screen, if you turn the VKbd on, and move the analog, you will see characters being printed in your save slot (this happens mostly with the diagonals, I think bottom-right and upper-right only). Also, the analog provides movement through save-slots, printed characters, or on the game selection at the Launcher. Tinsel (or Discworld) allows the mouse to be moved by the NUMPAD when on PC, so it's doing what it's supposed to...

Just for clarification: The VKeyboard is divided into 5 zones, which can be selected by the Dpad, one for each direction, and one for the default, no-direction (central) state. In each of the zones there are several characters/numbers, which can be accessed/typed by pressing on: Cross, Circle, Triangle, Square, LButton or RButton (while the VKbd is on, the Start button acts as Enter). The select button toggles whether the VKbd is on or off. The Analog should have no way of outputting text.

comment:3 by SF/nitrus, 8 years ago

Unrelated to controls printing text on the PSP, running Discworld on the PC, and using the NUMPAD to control the mouse allows the user to get the cursor out of the screen boundaries (indefinitely), and alters it's velocity too, so it speeds up.

comment:4 by bluegr, 7 years ago

There are two bugs here: one where the mouse cursor goes off screen, and the other where you see characters printed in save game descriptions when moving the DPAD while writing a savegame description. The first issue has been fixed with commit 468274a. Not sure about the second one, as I can't reproduce it.

If the first issue is fixed, I suggest creating a separate bug report with the second issue and close this one, to avoid confusion

comment:5 by bluegr, 7 years ago

Owner: set to bluegr

comment:6 by SF/nitrus, 7 years ago

Clipping was indeed fixed with the commit (for the PSP too of course). The other problems remain, but I agree that I should open a separate bug report for them, seeing as the original problem was solved.

comment:7 by bluegr, 7 years ago

Right, closing this one then. Please, file a separate bug reports for the other issue

comment:8 by bluegr, 7 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.