Opened 6 years ago

Closed 16 months ago

#6318 closed defect (outdated)

HOPKINS: Wrong palette for inventory icons on Wii

Reported by: SF/jennibee Owned by: csnover
Priority: normal Component: Engine: Hopkins
Keywords: Cc:
Game: Hopkins FBI

Description

I tested version 1.6.0git3390-g874b96b with Hopkins for BeOS/English on Wii.

The Wii version has the wrong palette for the inventory icons (when you use them as a mouse icon, they look OK when in the inventory screen). This only happens on Wii and not on Win32, so it might be a big endian vs little endian problem. I tried to take a screenshot, but the Wii version doesn't seem to support using Alt+S.

I've included a save from the end of the game, so as to have a scene with a lot of icons. All of them seem to have palette issues, it seems that red hues appear as blue.

Ticket imported from: #3612719. Ticket imported from: bugs/6318.

Attachments (1)

hopkins-beos.002 (9.0 KB) - added by SF/jennibee 6 years ago.
Save file from the end of the game

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by SF/jennibee

Attachment: hopkins-beos.002 added

Save file from the end of the game

comment:1 Changed 6 years ago by SF/jennibee

Component: Engine: Hopkins
Game: Hopkins FBI

comment:2 Changed 5 years ago by digitall

The BeOS version is rarer and we don't have a demo for it.

JenniBee: Could you try two things:
1. I am not sure about the "hue" issue you are seeing, so could you please try with the following DOS/Windows demos for Hopkins on your Wii:
https://sourceforge.net/projects/scummvm/files/demos/hopkins/

See if you can replicate the issue with them? The answer to this will tell us if this issue is BeOS game variant specific.

  1. In either case of the answer to the first point, but especially if this is BeOS variant specific, if you could see if you can replicate the issue in a PPC Big Endian virtual machine running Debian Linux for PPC. See here for HOWTO:
    http://wiki.scummvm.org/index.php/HOWTO-Debug-Endian-Issues

This assumes you don't have a PPC Mac lying around! :)

comment:3 Changed 5 years ago by digitall

Hmm... This could be the same problem as the color key issue fixed from bug #6108:
https://sourceforge.net/p/scummvm/bugs/6108/

Jennibee: Please can you confirm if this is still happening with the latest v1.7.0git Wii build please?

comment:4 Changed 16 months ago by csnover

Owner: set to csnover
Resolution: outdated
Status: newclosed

I am closing this ticket due to lack of response from OP to last query and an indication that this bug may have been fixed in the past. If it is still an issue, please reply and this can be reopened.

Note: See TracTickets for help on using tickets.