Opened 6 years ago

Last modified 12 months ago

#6310 new defect

HOPKINS: Credits roll flickering

Reported by: SF/tag2015 Owned by:
Priority: normal Component: Engine: Hopkins
Keywords: Cc:
Game: Hopkins FBI

Description

Game: Hopkins FBI
Game Version: Linux/English
ScummVM Version: 1.6.0git9383-gbef4610
Operating System: OSX 10.8.3

The text of the credits roll, shown at the end of the game, flicker badly.

Steps to reproduce:
1. load attached savegame
2. using hopkins, jump into the hole in the middle of the room
3. let the final sequence play automatically (credits appear after the cutscene where hopkins is working with his computer)

Ticket imported from: #3612482. Ticket imported from: bugs/6310.

Attachments (1)

hopkins-linux.004 (9.0 KB ) - added by SF/tag2015 6 years ago.

Download all attachments as: .zip

Change History (10)

by SF/tag2015, 6 years ago

Attachment: hopkins-linux.004 added

comment:1 by SF/tag2015, 6 years ago

Summary: Credits roll flickeringHOPKINS: Credits roll flickering

comment:2 by Strangerke, 6 years ago

Fixed in f286ae8f0757c9d645bfc29c424479829c12245b. The remaining flickering is related to the mouse refresh. I should be hidden, I think. But the current result is better by far imho

comment:3 by Strangerke, 6 years ago

Resolution: fixed

comment:4 by Strangerke, 6 years ago

I hid the mouse, it's a bit better.
There's still a very subtle flickering when the mouse is moved... I don't see how I can improve that right now

comment:5 by Strangerke, 6 years ago

Status: newpending

comment:6 by SF/greencis, 6 years ago

Android 4.0.3, ScummVM 1.7.0git42-g2474726 (May 14 2013 06:08:53)
Windows XP 32bit, ScummVM 1.7.0git42-g2474726 (May 14 2013 07:34:03)

Hopkins FBI Win95 UK and Russian versions

This bug is still present! Credits still flicker in the end. In original versions, they don't flicker.

comment:7 by Strangerke, 6 years ago

Resolution: fixed
Status: pendingnew

comment:8 by digitall, 12 months ago

Replicated with attached savegame and latest git master on Linux x86_64 with Windows variant of game.
The credits flicker as described.

The credits room is 100 from debug console.
Doing "show_rects" in the console indicates the likely cause of the issue to be the dirty rects code in the engine. There is a large rect covering the entire credits area and then smaller rects for each of the credits items. I think either an original engine code issue with this i.e. drawing a background and then redrawing is conflicting with the dirty rects code or there is a corner case here.

Will try and investigate further.

comment:9 by digitall, 12 months ago

Have added code to help debug this as commit 4f077f2b5a747dc2794060bf486c79b6d7eb0030.

This now adds a debugflag of "graphics" to the HOPKINS engine which at debug level 1 outputs messages on OSystem calls to update screen, and copy pixels to screen.

Based on observing this during the credits, the issue appears to be the dirty rect / rect update oscillating between a single rect to update the entire credits and single rects for each credit item. Not sure if that is the root cause or just a symptom of the issue though...

Note: See TracTickets for help on using tickets.