Opened 6 years ago

Closed 5 years ago

#6291 closed defect (fixed)

HOPKINS: speech cuts music

Reported by: misterhands Owned by: dreammaster
Priority: normal Component: Engine: Hopkins
Keywords: Cc:
Game: Hopkins FBI

Description

Latest Win64 daily
Hopkins Win FR

In some cases speech cuts the music. Load the attached savegame and do something to trigger speech,
for example, look at the statue. That kills the music.
Note that it only seems to happen after the first savegame loading.
If after that you load another savegame (which restores music) and try again, the bug doesn't happen.

Ticket imported from: #3611824. Ticket imported from: bugs/6291.

Attachments (1)

hopkins-win-fr.001 (8.8 KB) - added by misterhands 6 years ago.

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by misterhands

Attachment: hopkins-win-fr.001 added

comment:1 Changed 6 years ago by Strangerke

Owner: set to Strangerke

comment:2 Changed 6 years ago by Strangerke

Owner: changed from Strangerke to dreammaster

comment:3 Changed 6 years ago by Strangerke

Can't reproduce in my environment. Attributing to dreammaster for another check.

comment:4 Changed 6 years ago by SF/tag2015

I can reproduce this consistently. It only occurs if you load a savegame from scummvm's launcher (and it happens in every location) . If you start the game and then load a savegame from the main menu or gmm instead, everything is normal.

comment:5 Changed 6 years ago by Strangerke

Reproduced... I wasn't testing it properly. Thanks for the info, I'm on it.

comment:6 Changed 6 years ago by Strangerke

Fixed in 8191e74f1f86557668bfe5c76815d30f1a5129e7

comment:7 Changed 6 years ago by Strangerke

Resolution: fixed
Status: newpending

comment:8 Changed 6 years ago by misterhands

Seems to be fixed. However when triggering speech, the music volume drops now.

comment:9 Changed 5 years ago by Strangerke

Pending-Fixed for over a year - Closing

comment:10 Changed 5 years ago by Strangerke

Status: pendingclosed
Note: See TracTickets for help on using tickets.