Opened 7 years ago

Closed 17 months ago

#6288 closed defect (fixed)

DREAMWEB: Spanish speech ends abruptly during intro

Reported by: (none) Owned by: bluegr
Priority: normal Component: Engine: Dreamweb
Keywords: Cc:
Game: Dreamweb

Description

ScummVM 1.5.0 and ScummVM 1.6.0git3848-g1cec3be (Apr 22 2013 19:49:25)

Dreamweb CD/DOS/Spanish, talkie version of scummvm.org

Windows 7 32-bit

Problem with voice on the intro, some sentences end abruptly in the end

Ticket imported from: #3611587. Ticket imported from: bugs/6288.

Change History (10)

comment:1 by (none), 7 years ago

Summary: DREAMWEB: audio speech end suddenlyDREAMWEB: audio speech ends suddenly

comment:2 by digitall, 7 years ago

secreto: Thank you for the bug report. Could you please try the following:

The Spanish CD release of Dreamweb from our website i.e. dreamweb-cd-es-1.0.zip includes the original DOS executable engine. Please can you try running the game under DOSBox: http://www.dosbox.com/ and see if the same behaviour is observed there?

comment:3 by digitall, 7 years ago

Summary: DREAMWEB: audio speech ends suddenlyDREAMWEB: Spanish speech ends abruptly during intro

comment:4 by (none), 7 years ago

Yes I did it, and worked well in DOSBox.

comment:5 by digitall, 7 years ago

secreto: OK thanks. Since most of the developers don't speak Spanish, could you watch the intro in English and identify one of the incorrect lines in English and then the equivalent in the Spanish version here and where the truncation occurs udring the line. If you could describe this, it would help.

comment:6 by wjp, 7 years ago

A transcription of the relevant lines in Spanish would already be enough, I think.

comment:7 by (none), 7 years ago

I pointed the truncated part of the words with a slash and placed the lines of uk version below for reference
These are the lines:

La Tela de Sueños no ha cambia / do en siglos...

For centuries the Dreamweb has been stable...

"Guardianes. La Tela de Sueños se está deshacien / do poco a poco."

"Keepers. The web of dreams is slowly unwinding."

"Si sehacen demasiado poderosos, la Tela de Sue / ños será destruida."

"If they become too strong the Dreamweb will be destroyed."

"Si descubren sus poderes, se harán demasiado fuer / tes."

"If they discover their powers they will become too strong."

"Sí, y ha crecido con fuerza. Él empi / eza a agitarse."

"Yes. It has grown strong and he is stirring."

comment:8 by digitall, 7 years ago

secreto: Thank you for this. We should have sufficient detail to investigate this bug now, but it may take some time for a developer to get round to looking at this. Please be patient and standby.

comment:9 by digitall, 6 years ago

Minor update. This is likely to be the same issue as bug #6417 "DREAMWEB: Intro speech truncated in German Version":
https://sourceforge.net/p/scummvm/bugs/6417/

There is a tricky minor regression in the monks2text function which is causing this. More details on that bug.

comment:10 by bluegr, 17 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

The Spanish version is using the same timings in that scene as the German one.

This bug should finally be fixed in commit fc5261b0c4.

Note: See TracTickets for help on using tickets.