Opened 8 years ago

Closed 3 months ago

#6275 closed defect (duplicate)

GROOVIE: T7G - MIDI polyphony bug

Reported by: misterhands Owned by:
Priority: normal Component: Engine: Groovie
Keywords: Cc:
Game: 7th Guest

Description

Latest w64 daily build T7G DOS English

Sometimes after playing a puzzle for a while, the music stops and ScummVM freezes, with this warning: WARNING: MidiParser::hangingNote(): Exceeded polyphony!

This happened to me once in the Bishop puzzle, but it seems to happen pretty consistently on the microscope puzzle if you play it long enough (which you pretty much have to, that one is tough !)

Also the game throws a : WARNING: Unsupported XMIDI controller 114 (0x72)! but this one happens regularly during normal game-play so it may be unrelated to this bug.

Ticket imported from: #3610959. Ticket imported from: bugs/6275.

Attachments (1)

t7g.005 (120 bytes ) - added by misterhands 8 years ago.

Download all attachments as: .zip

Change History (3)

by misterhands, 8 years ago

Attachment: t7g.005 added

comment:1 by misterhands, 7 years ago

It looks like this could be a duplicate of an old yet unresolved MIDI bug : MIDI: MidiParser::hangingNote(): Exceeded polyphony! - ID: 2797283

https://sourceforge.net/tracker/?func=detail&aid=2797283&group_id=37116&atid=418820

comment:2 by raziel-, 3 months ago

Resolution: duplicate
Status: newclosed
Summary: T7G: MIDI polyphony bugGROOVIE: T7G - MIDI polyphony bug

Duplicate of #4354

Note: See TracTickets for help on using tickets.