Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#6273 closed defect (invalid)

SCI: SQ5: Cannot get banana at Kiz Urazgubi

Reported by: SF/negativeiq Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Space Quest 5

Description

At Kiz Urazgubi there's a part where you're supposed to push a banana-like fruit using a stick from your inventory so it swings back and forth so you can pick it up.
For some reason with ScummVM 1.5.0 (at least on my computer) using the stick on the fruit does nothing - just keeps the usual messages that appear if you try to combine stuff that doesn't work together.

Ticket imported from: #3610481. Ticket imported from: bugs/6273.

Attachments (1)

sq5.002 (44.3 KB ) - added by SF/negativeiq 7 years ago.
Savegame reproducing the bug

Download all attachments as: .zip

Change History (8)

comment:1 by wjp, 7 years ago

Summary: Cannot get banana at Kiz UrazgubiSCI: SQ5: Cannot get banana at Kiz Urazgubi

comment:2 by wjp, 7 years ago

Could you attach a savegame?

by SF/negativeiq, 7 years ago

Attachment: sq5.002 added

Savegame reproducing the bug

comment:3 by SF/negativeiq, 7 years ago

Savegame added. You're supposed to use the banana on the vine.

EDIT: OK, apparently if you use it on a spot a little above the fruit it does work. I still think in the original engine it should work if you use it on the fruit itself but it's now a minor issue.

comment:4 by bluegr, 7 years ago

This is working as expected - the hotspot for the branch cursor is in the lower left of the cursor (x = 3, y = 7), which is consistent with the way that the cursor is drawn. If you click using the lower left edge, then the item interactions work as expected. Could you please verify that it's working for you this way?

comment:5 by bluegr, 7 years ago

Owner: set to bluegr
Resolution: worksforme
Status: newpending

comment:6 by bluegr, 5 years ago

Resolution: worksformeinvalid
Status: pendingclosed

comment:7 by bluegr, 5 years ago

It's been more than a year, and the poster hasn't replied, thus I'm assuming that the issue has been resolved - the hotspot of that cursor is in the lower left of the cursor, which seems to have confused the user.

Closing as invalid

Note: See TracTickets for help on using tickets.