Opened 7 years ago

Last modified 5 years ago

#6271 new defect

DW1: Can't take custard book

Reported by: SF/thetomaso Owned by: bluegr
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

When talking to the Witch at the Square (near the end of Act II), sometimes you can't pick up the Custard Book when the Witch is trying to kiss you.
I say "sometimes", because after messing around with some of ScummVM's settings, I got it to work..
Strange enough, I when I finally got it to work, it was with the same settings that I had in the first place.

First reported on Oct 22, 2010, by davidk64 here:
http://forums.scummvm.org/viewtopic.php?p=62367#62367

(Playing with files from my original CD, under WinXP32/SP3, using ScummVM v1.5.0)

Ticket imported from: #3610254. Ticket imported from: bugs/6271.

Attachments (1)

dw-cd.009 (3.9 KB ) - added by SF/thetomaso 7 years ago.
Savegame

Download all attachments as: .zip

Change History (16)

by SF/thetomaso, 7 years ago

Attachment: dw-cd.009 added

Savegame

comment:1 by SF/thetomaso, 7 years ago

Oh yeah, my CD is the UK "Argentum Collection" DOS release.

comment:2 by wjp, 7 years ago

Summary: Discworld (1) - Can't take custard bookDW1: Can't take custard book

comment:3 by SF/thetomaso, 7 years ago

What happens is that when the Witch is trying to kiss you, the cursor disappears.
When the sequence has finished, the cursor reappears, but by then it's too late to pick up the book.

comment:4 by bluegr, 6 years ago

I don't see a bug here, I was able to pick up the book normally with your saved game.

When the witch wants to kiss you, the cursor appears after Rincewind says "Ulp!". You have about 2 seconds or so to take the book. It's part of the riddle in that scene, and its behavior looks perfectly normal to me - the delay is small, but that's how the original works too. Have a look at this youtube video of this part:
http://www.youtube.com/watch?v=ylnp6t-I6uk#t=2m30s

So... it all looks perfectly fine to me, i.e. it doesn't look like a bug in ScummVM itself, you just have to be a little quick when doing this sequence.

Closing as invalid, but I'm leaving comments on in case there's something else

comment:5 by bluegr, 6 years ago

Owner: set to bluegr
Resolution: invalid
Status: newclosed

comment:6 by SF/thetomaso, 6 years ago

No, don't close the report!

Obviously, this is a bug that only happens sometimes, or under certain circumstances.
In that YouTube video, the bug doesn't happen, and the book could be picked up without any problem.

All I can say is that I'm 100% SURE that there is a bug, because I knew what was supposed to happen at that point in the game, but the pointer remained hidden the entire time when the witch tried to kiss Rincewind.
This made me search the ScummVM forum for the word "custard", and I found the post that I linked to in my initial report.
Afterwards, I fiddled around with ScummVM's settings for a while, and suddenly after 5-6 tries the pointer became available when it was supposed to, and I was finally able to pick up the book!
I have no idea what made it work, because as I previously wrote, ScummVM's setting at that point were the same as it was in the first place.

Very strange indeed..

Anyway, the bug is a serious one, because if you don't know what's supposed to happen at that point in the game, you'll be unable to proceed.
..and of course, we all know how many hours of frustration that could lead too :)

comment:7 by bluegr, 6 years ago

Reopened

The only setting I can think of that may modify this scene is the subtitle speed. Try tweaking it to see if that's the cause

comment:8 by bluegr, 6 years ago

Resolution: invalid
Status: closednew

comment:9 by SF/thetomaso, 6 years ago

I did some further testing, and I think you can root out the subititles as a cause.
It doesn't matter if I set the subtitle speed to "0", "255", or even if I disable them entirely..
The bug happens EVERY time for me now!

I will do some more testing..

comment:10 by SF/thetomaso, 6 years ago

I realize now that I was lucky to get past this point the last time, because now I can't get it to work no matter what I do!

I found this though (serach for the word "custard"):
http://db.gamefaqs.com/computer/doswin/file/discworld.txt
..it mentions a bug in the game itself, which supposedly happens around that exact same place.
Could it be related somehow?

comment:11 by SF/thetomaso, 6 years ago

I get this in the log:

[2013-04-02 16:26:14] ScummVM 1.5.0 (Jul 21 2012 12:28:22)
[2013-04-02 16:26:14] Vorbis FLAC MP3 RGB zLib FluidSynth Theora AAC FreeType2
[2013-04-02 16:26:14] --- Log opened.
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 100 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 6 (2)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 11 (127)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 101 (0)!
[2013-04-02 16:27:04] WARNING: AdLib: Unknown control change message 116 (0)!
[2013-04-02 16:28:14] --- Log closed successfully.

comment:12 by SF/thetomaso, 6 years ago

I tried setting Music Device to "No music"..
This made the errors in the Status Window disappear, but it didn't do anything to help with the bug.
In fact, those errors doesn't seem to have any impact on gameplay at all, as far as I can tell.

comment:13 by SF/thetomaso, 6 years ago

OK. I've done some more testing now, and I've found a workaround!

It seems that you were right about the subtitle speed being the culprit after all.
Damn, I really should have tested that bit to a greater extent when you first mentioned it! :)

Anyway, here's the workaround:
1) Set the Subtitle speed to "0" (or disable subtitles entirely).
2) When the Witch tries to kiss Rincewind, quickly click the left mouse button twice to skip these two sentences:
- "Erk, ulp!"
- "Ah... no thanks, I'll pass."
3) Quickly pick up the Custard Book before the Witch gives up on her kissing attempt.

If possible, I guess that this bug could be fixed in ScummVM by just shortening these two specific subtitle sentences by force?

comment:14 by SF/thetomaso, 5 years ago

New computer, different OS, new version of ScummVM (v1.7.0)..
The bug remains:
With ScummVM's default subtitle speed, it's impossible to pick up the custard book without the use of a workaround (dialog needs to be skipped).
In other words; gameplay is broken and players that don't know what's supposed to happen at that point will be unable to continue the game!

comment:15 by eriktorbjorn, 5 years ago

The default "talkspeed" in the Tinsel engine is 0, but that's overridden if the [scummvm] section of the config file has it set.

I don't know enough about the Tinsel engine to work around the problem, but perhaps it could be mitigated by having Tinsel ignore any outside "talkspeed" setting. I.e. in Config::readFromDisk(), instead of checking if (ConfMan.hasKey("talkspeed")), it could probably check if (ConfMan.hasKey("talkspeed", ConfMan.getActiveDomainName())).

Or something like that, I'm not sure.

Note: See TracTickets for help on using tickets.