Opened 7 years ago

Closed 4 years ago

#6270 closed defect (fixed)

KYRA2: Intro doesn't skip righ/Game won't start on first run

Reported by: eriktorbjorn Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 2

Description

The first time you start Kyrandia 2, and there are no savegames, the game skips the menu and goes straight to the intro. (This was not the case in 1.5.0, but I assume it's deliberate in the development version.) However, there are two problems:

1) If you try to skip the intro, it doesn't skip it properly, it just cuts each scene short.
2) Once the intro has ended, ScummVM quits.

The first problem appears to have something to do with the _loopStartScene == kSequenceLooping case in SeqPlayer_HOF::checkPlaybackStatus().
The second appears to be because _result is never set, so it remains zero. If I force it to be 1 at the end of the intro, the game seems to start properly.

Ticket imported from: #3610247. Ticket imported from: bugs/6270.

Change History (9)

comment:1 by eriktorbjorn, 7 years ago

Summary: KYRA2: Can't skip intro/Game won't start on first runKYRA2: Intro doesn't skip righ/Game won't start on first run

comment:2 by eriktorbjorn, 7 years ago

Another regression is that if I skip the intro (in the normal case, where I do have a saved game), the animation of the hand before the menu appears isn't displayed. This seems to be because _result is still 2 from selecting to run the intro. I'm not sure where it would be the most appropriate to clear it.

comment:3 by eriktorbjorn, 7 years ago

The forum post that mentioned these problems [1] also said something about the intro running too quickly. It's not obviously wrong to me, and it may depend on subtitle settings, but it may be a good idea to compare it to DOSBox. The musical sting when Zanthia discovers someone has stolen her stuff is the only part of the intro I can think of where the music and action are connected, though.

[1] http://forums.scummvm.org/viewtopic.php?t=12344

comment:4 by athrxx, 7 years ago

Thanks for the report. I can't look into that right now (since it also involves some comparison with disasm) but I'll try to fix the bug over the next couple of days.

comment:5 by athrxx, 7 years ago

This should now be fixed. Please try with the latest build.

comment:6 by athrxx, 7 years ago

Resolution: fixed
Status: newpending

comment:7 by eriktorbjorn, 7 years ago

Status: pendingnew

comment:8 by eriktorbjorn, 7 years ago

There's a slight glitch with Faun disappearing/reappearing at the end of the intro, but I don't think that was caused by this bugfix. Other than that, it seems to work now. (Though you may want to ask the guy who brought it up on the forum, too.)

comment:9 by sev-, 4 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.