Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6252 closed defect (fixed)

SCI KQ6: No music during/after spider interaction

Reported by: SF/dmwarren Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

What/when/where:
No music during/after interaction with spider on the bookworm screen on the Isle of Wonder.
Save games for newer and older 1.6 file formats attached.

Which:
KQ6 Windows/CD version

Steps to reproduce:
1) Load saved game (attached).

2) Go east.

3) [Talk] to spider.
There should be music in this room but there is none audible.

4) [Hand] on hanging thread (bottom of the screen)
and then quickly [hand] on the piece of paper (top of the screen)
When the animation sequence finishes and the view changes back to the "bookworm" room on the Isle of Wonder, the background music stops.

Earliest 1.6.0 build where bug is *not* present:
1.6.0git36-ga97f446 (~July 2012)

Earliest build I know of where bug is present:
1.6.0-git2628-g61ec6c9 (~Feb 2013--not very far back, sorry)

Bug is not present in final release of 1.5.0.

Let me know if you need more info/testing. :-) Thanks for all the ScummVM team's hard work.

Ticket imported from: #3605377. Ticket imported from: bugs/6252.

Attachments (1)

kq6-spider-music-bug-games.zip (81.8 KB) - added by SF/dmwarren 6 years ago.
Savegames for KQ6 CD-ROM/Win - newer/older 1.6 file formats

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by SF/dmwarren

Savegames for KQ6 CD-ROM/Win - newer/older 1.6 file formats

comment:1 Changed 6 years ago by SF/mmp31

I am having this same problem as well. The music also disappears when going down to the lower level of the catacombs, right after lighting the torch.

comment:2 Changed 6 years ago by bluegr

Fixed in commit 17ca8d1 - the fix should be available in the next daily version

comment:3 Changed 6 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:4 Changed 6 years ago by bluegr

The problem is the same as in bug #3267956:
https://sourceforge.net/tracker/index.php?func=detail&aid=3267956&group_id=37116&atid=418820

Note: See TracTickets for help on using tickets.