Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#6245 closed defect (fixed)

LURE: ANDROID, Action item scrolling too sensitive

Reported by: (none) Owned by: digitall
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

When interacting with an object in the game, you get a list of possible actions to take. However, if there is more than two, the items in the middle cannot be scrolled to, the scroll simply zooms to the end of the list. It's possible to get to those to those action items, but very very difficult, as it requires scrolling in pixel increments. Sadly, it makes the game pretty much impossible to play.

Issue reproducible on Play Store version, as well as nightly 1.6.0git2625-gadc338c (12th Feb).

I've confirmed it works fine on the stable Mac build of 1.5.0.

Ticket imported from: #3604370. Ticket imported from: bugs/6245.

Change History (4)

comment:1 by (none), 7 years ago

This happens on my Nexus 4 with Android 4.2.1.

comment:2 by (none), 7 years ago

Okay, a pull request has just been submitted for this on GitHub.

You can't scroll the menus properly because the code assumes it can reposition the mouse cursor to the middle of the screen, so as soon as you move the threshold number of pixels off with your finger on android, the menu scrolls right to the end. The fix is simply to state that Android can use the clickable menus feature already implemented.

I guess other touch devices (e.g. iOS) will need a similar change too.

comment:3 by digitall, 7 years ago

Owner: set to digitall
Resolution: fixed
Status: newclosed

comment:4 by digitall, 7 years ago

karadoc: Have merged Pull Request 311 as commit f70905d979953fc52954ba5f7d8b4ae149179a56. Closing this bug as fixed.

Note: See TracTickets for help on using tickets.