Opened 5 years ago

Last modified 19 months ago

#6242 new defect

AUDIO: Built-In MT-32 MUNT Produces Wrong Sounds

Reported by: SF/zosite Owned by: lordhoto
Priority: normal Component: --Unset--
Keywords: Cc:
Game:

Description

I was going to report this bug as a comment to #3602982, but that one has already been set as duplicate of #3038752. In fact, it could be the very same issue but I'm not entirely sure so I'm opening this new entry; if it's found to be another duplicate please accept my apologies and feel free to add it as yet another comment to the parent one.

This problem mentioned by algernon64 on missing/wrong instruments being played when MUNT 1.0 standalone Windows MIDI driver is being used by ScummVM for MIDI output also happens with ATLANTIS and MONKEY2 as described below:

- MONKEY2: the (nasty) sound of spitting when choosing game difficulty between normal and easy, right at the beginning of the game, is clearly wrong.

-ATLANTIS: the sound of window being crashed by Indy when making his very first appearance at the beginning of the game is also wrong; sounds like some kind of... bell?

All this happens when using MUNT 1.0 standalone driver, but unlike #3602982 this DOES NOT happen when using ScummVM implemented MT-32 Emulator (also based on current MUNT source code AFAIK) and both sounds are played correctly. However, I also tried an older build of the MUNT driver from around July 2011 and it worked; odd, since as said above current MUNT source and ScummVM have been using the same code for some time now or so I heard.

On the other hand, there's no problem when using the very same standalone driver under DOSBox 0.74 with the original games.

BTW, I also noticed that ScummVM Emulator doesn't accept CM32L_PCM.ROM and CM32L_CONTROL.ROM on its latest daily snapshots and it's looking for MT32_PCM.ROM and MT32_CONTROL.ROM only; it may works (or so it seems) if you just rename the files but both ROM versions used to work flawlessly with older builds.

Used both ScummVM 1.5.0 and latest daily snapshot (win32)
Used MUNT 1.0.0 (SourceForge) for win32 standalone driver
Also used MUNT snapshot from around July 2011
Used Indiana Jones and The Fate of Atlantis (DOS/Floppy/Spanish & English)
Used Monkey Island 2 (DOS/Floppy/Spanish)
Used DOSBox Daum SVN build from 2011-07-05
Used both SDL_VIDEODRIVER = directx & windib
Used both SDL_AUDIODRIVER = dsound & waveout

BTW, for some reason dsound and directx values for those SDL environment variables above don't seem to work anymore for me, though I hardly doubt this issue is related to the MT-32 problem.

Ticket imported from: #3603091. Ticket imported from: bugs/6242.

Attachments (1)

MUNT.reg (3.0 KB) - added by SF/zosite 19 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 5 years ago by lordhoto

Just checking: You use "True Roland MT-32 (disable GM emulation)" in the MT-32 tab in the options when you are using the Win32 standalone driver?

comment:2 Changed 5 years ago by SF/zosite

Sure I did! Both with the standalone driver and the implemented Emulator, though I take the code just ignores this setting in this last case for it's obvious you don't need any conversion to GM.

comment:3 Changed 5 years ago by bluegr

The problem with the CM32L_* ROMs has been fixed in commit 059f5ee

comment:4 Changed 5 years ago by SF/zosite

Indeed it has been fixed! Thanks a lot. Moreover, dsound and directx values for SDL win32 environment variables are being accepted again so you can disregard that issue too.

However, I'd like to add here another problem I've found which I think it fits with current bug description:

In 'The 7th Guest', using the implemented MT-32 Emulator triggers some ugly echoes whenever music themes change or a cinematic is about to end. This DOES NOT happen with the standalone win32 MUNT driver, so this time is the driver which is working as expected. Then again, since they're supposed to be using the same code this shouldn't happen.

In order to test this particular issue it'd be enough to click on mansion's main door (the one with stained glass) at the beginning of the game; a cinematic featuring Mr.Dutton will begin and those echoes will appear at the end if the implemented emulator is being used instead the driver.

Then again, this issue was tested with the very last daily win32 snapshot.

comment:5 Changed 4 years ago by bluegr

Our internal MUNT version has been updated to 1.3.0... can you please test both the stand-alone MUNT driver, version 1.3.0 and a daily version of ScummVM?

comment:6 Changed 3 years ago by SF/zosite

I've tested both ScummVM 1.7.0 and latest development build (Aug 10th) and the problem with the echo sounds on T7G is still there using the implemented MT-32 Emulator.

Moreover, the aforementioned problem with the sound of window being crashed on ATLANTIS, which was happening only under MUNT standalone 1.0.0 driver, is now happening under implemented MT-32 Emulator too on both ScummVM versions! Not the MONKEY2 one though.

Sadly, I didn't have time to install and test MUNT 1.3.0 win32 standalone driver yet so I'm testing ScummVM 1.7.0 + latest daily build against MUNT 1.0.0 win32 driver. The rest of my settings remain the same.

comment:7 Changed 3 years ago by SF/zosite

Ok, I finally managed to install and try MUNT win32 standalone driver v1.4.0, and I can say NONE of the aforementioned issues are present when using it under ScummVM.

Therefore, until these problems are fixed I'm gonna use the driver instead the implemented MT-32 Emulator which is said to be using official MUNT 1.3.0 engine.

Additionally, when comparing against 1.4.0 standalone driver I found that the problem with the sound of spitting when choosing game difficulty on MONKEY2 is there again: it doesn't sound like a sustained bell anymore but now it features some strange reverb effect not present when using the standalone driver.

I wish you the best on fixing these issues; I'll be right here to try new daily snapshots under request.

comment:8 Changed 20 months ago by SF/zosite

This one is still running! I'm now using ScummVM 1.8.0 and the problem persists. In short:

With ScummVM internal MT-32 emulator (CM32L ROMs):

ATLANTIS: sound of window being crashed by Indy when making his very first appearance at the beginning of the game is wrong; sounds like some kind of bell...

MONKEY2: the sound of spitting when choosing game difficulty between normal and easy, right at the beginning of the game, is not exactly wrong anymore, but it has some extra reverb added to it which isn't supposed to be there.

T7G: no further problems; please disregard the issue mentioned above.

With ScummVM using MUNT 1.5.0 win32 driver (driver version 1.1.1) and same ROMs:

NO problems

With DOSBox SVN-Daum (last build) using the very same driver + ROMs:

NO problems

comment:9 Changed 20 months ago by lordhoto

This looks like a regression from 00992c1e68444a8123ffc89a971751cecf7287ed. I will investigate this further tomorrow.

comment:10 Changed 20 months ago by lordhoto

Owner: set to lordhoto
Summary: MUNT win32 driver vs. Implemented MT-32 EmulatorAUDIO: Built-In MT-32 MUNT Produces Wrong Sounds

comment:11 Changed 19 months ago by lordhoto

The Indy4 sound effect issues has been fixed with 1ed261dac48bf307f1a670117c683eb7dd60ce07.

The Monkey Island 2 issue is a bit odd, this almost certainly has to happen with the Win32 driver and default configuration of it too. Do you have any specific configuration settings you use for the Windows driver for MUNT? Or do you use the default configuration?

comment:12 Changed 19 months ago by SF/zosite

No, I'm always using default configuration with one single exception: my output gain is 1.5 instead 1.0 but I hardly doubt this would change anything. However, please remember I'm using 1.1.1 version of the driver (available as standalone download here at SF) and not the 1.1.0 included with the 1.5.0 MUNT package, just in case.

Thanks for the Indy4 fix btw.

comment:13 Changed 19 months ago by lordhoto

1.1.1 and 1.1.0 aren't too different. Can you attach the full configuration you are using?

Changed 19 months ago by SF/zosite

Attachment: MUNT.reg added

comment:14 Changed 19 months ago by SF/zosite

Sure thing. Find here a registry dump.

Note: See TracTickets for help on using tickets.