Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6241 closed defect (duplicate)

SCI: Longbow: MT32 does not sound right

Reported by: SF/algernon64 Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Conquests of the Longbow

Description

I'm using the MT-32 Emulator from MUNT (latest version 1.0) that installs as a MIDI device in Windows to play music (I also note that the same thing happens when using scummvm's built in MT-32 emulator).

In scummvm, I've configured Scummvm to use the MT-32 Emulator (Windows) MIDI device, and I've also checked the options "Override global MT-32 settings" and "True Roland MT-32" so that scummvm sends MT-32 midi music to the emulator. I watched the introduction of the game and while the music *is* MT32 music, I noticed that in some sections it doesn't sound completely right, as if there are some instruments missing.

To compare, I ran the game in Dosbox and also configured Dosbox to use the same MIDI device (MT-32 Emulator in Windows). In dosbox, the music sounds right throughout the introduction.

So, it appears to me that the engine in scummvm is not sending all MT-32 midi commands to the midi device.

I tested this in ScummVM 1.6.0git2489-g45f95cb (Jan 15 2013 09:44:26) win32 Conquest of Longbow (English version)

Ticket imported from: #3602982. Ticket imported from: bugs/6241.

Change History (3)

comment:1 by SF/algernon64, 7 years ago

Summary: MT32 does not sound rightSCI: Longbow: MT32 does not sound right

comment:2 by bluegr, 7 years ago

Duplicate of bug #3038752 - "SCI: Missing music instruments"

Closing as duplicate - I'll attach the information in the other bug

comment:3 by bluegr, 7 years ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.