Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6235 closed defect (fixed)

TOLTECS: Game crashes during video sequence

Reported by: SF/schroedm Owned by: bluegr
Priority: normal Component: Engine: Toltecs
Keywords: Cc:
Game: 3 Skulls of the Toltecs

Description

After using the key to open the oracle's door a video sequence starts where Fillmore and the others place their skulls. While playing that sequence ScummVM crashes. I used the german/dos version of the game. The bug already exists in the daily build from January 19th, 2013.
A savegame is attached. If there are any questions feel free to contact me.

Ticket imported from: #3601567. Ticket imported from: bugs/6235.

Attachments (1)

toltecs-de.014 (39.2 KB ) - added by SF/schroedm 7 years ago.
Savegame

Download all attachments as: .zip

Change History (7)

by SF/schroedm, 7 years ago

Attachment: toltecs-de.014 added

Savegame

comment:1 by SF/schroedm, 7 years ago

Summary: Game crashes during video sequence3SkullsTollecs: Game crashes during video sequence

comment:2 by SF/schroedm, 7 years ago

Summary: 3SkullsTollecs: Game crashes during video sequence3SkullsTolltecs: Game crashes during video sequence

comment:3 by lordhoto, 7 years ago

Summary: 3SkullsTolltecs: Game crashes during video sequenceTOLTECS: Game crashes during video sequence

comment:4 by bluegr, 7 years ago

This is caused by memory corruption. There's a subtitle that is supposed to appear, but it somehow corrupts memory and leads to all sorts of invalid reads. Disabling the subtitle code shows the video correctly. We'll need to trace where this memory corruption occurs

comment:5 by bluegr, 7 years ago

Thanks for your report. Fixed in commit 93763ac. The fix should be available in the next daily build

comment:6 by bluegr, 7 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.