Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#623 closed defect (duplicate)

Dig: NPC speech interrupted too early

Reported by: SF/bugzapper Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Win32 0.3.0b and 0.3.1cvs (2002-12-04) Full Talkie English version

Certain bits of character speech are either getting interrupted by the next bit of speech too early or they're just not playing to completion.

I've attached a save game example [in the 0.3.1cvs (2002-12-04) format]. When you restore it, click the shovel on the asteroid boulder. A animation will play and then a conversation will occur. Eventually Cora says:

"Careful, Ken. You don't want to find yourself getting quoted as a sexist pig in Maggie's article."

To which Maggie responds:

"I'm not here to spy on you."

But it doesn't play out like that under SCUMMVM.
Instead, Maggie interrupts cora in the middle of the word "pig" and the rest is cut off.

Ticket imported from: #651631. Ticket imported from: bugs/623.

Attachments (1)

dig.s09 (72.5 KB ) - added by SF/bugzapper 17 years ago.
Buggy speech example savegame

Download all attachments as: .zip

Change History (6)

by SF/bugzapper, 17 years ago

Attachment: dig.s09 added

Buggy speech example savegame

comment:1 by SF/bugzapper, 17 years ago

Summary: Dig: NPC speech interrupted to earlyDig: NPC speech interrupted too early

comment:2 by SF/bugzapper, 17 years ago

Another example is -- after you've placed and armed both nuclear explosives and you ask brink about the explosives.
He'll eventually say:

"The low gravity of this asteroid suggests that it is either hollow or porous."

The last syllable of porous get cut off by his next sentence.

comment:3 by SF/bugzapper, 17 years ago

Oops, looks like this matches bug #635008.

Sorry (at least now you have a savegame I guess :p)

comment:4 by fingolfin, 17 years ago

Duplicate of #635008

comment:5 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.