Opened 6 years ago

Closed 6 years ago

#6226 closed defect (fixed)

EOB1: Crash when moving in German version

Reported by: SF/goinz Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Eye of the Beholder 1

Description

heya, just noticed a scumm crash while playing eob1, simply by walking along a corridor. guess osme script event is going to happen there.
there are no errors printed in the console window, instant termination of scumm.
as the compatiblity list says the game is completable there we go =)
ok, here the specific infos
- os is win7x64 home premium sp1
- scummversion is daily build for win64 (11.01, 1.6.0git2477-g41725ab) , and tried win32 dailybuild with the same result.
- game is a german dos version of eob1
- save file is attached, to reproduce simply move forward 1 step. (also list of eob1 game folder and my config file)
- sidenote > on scumm startup i get a warning message "sdl mixer output buffe sizer :5512 differs from desired : 2048!" not sure if that copes with the crash
when i get scumm daily running on my debian (always crashing) i will try there and let u know.

have fun =)

Ticket imported from: #3600348. Ticket imported from: bugs/6226.

Attachments (1)

eob1.7z (20.7 KB) - added by SF/goinz 6 years ago.
savefile

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by SF/goinz

Attachment: eob1.7z added

savefile

comment:1 Changed 6 years ago by SF/goinz

Summary: instant crashEOB1: instant crash

comment:2 Changed 6 years ago by lordhoto

It seems to be a crash specific to the German version. With my English copy of the game I don't get any crash when I try to move after loading that save game. Then again when I compare the thumbnail to the level layout I get when loading the save it's different...

comment:3 Changed 6 years ago by lordhoto

Summary: EOB1: instant crashEOB1: Crash when moving in German version

comment:4 Changed 6 years ago by lordhoto

Owner: set to athrxx

comment:5 Changed 6 years ago by athrxx

This should now be fixed. Please try with the latest build.

comment:6 Changed 6 years ago by athrxx

Status: newpending

comment:7 Changed 6 years ago by athrxx

Resolution: fixed

comment:8 Changed 6 years ago by SF/goinz

>_- yep works now. gr8 job!
regards

comment:9 Changed 6 years ago by SF/goinz

Status: pendingnew

comment:10 Changed 6 years ago by wjp

Status: newclosed
Note: See TracTickets for help on using tickets.