Opened 7 years ago

Closed 4 months ago

#6218 closed defect (fixed)

SCI: KQ4 - Hat doesn't go off screen during intro

Reported by: SF/envisaged0ne Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 4

Description

During the intro, when Graham tosses his hat towards his children, there is a cut scene where they show the hat twirling through the air. The hat is supposed to completely go off screen before switching to a close up of Graham. However, it doesn't, and when it switches to graham, you can see the hat frozen in the air.

Using the latest daily snapshot, but this has been a bug for a long time. Running Win 7 32 bit. To reproduce, just watch the intro, up to the part where graham tosses his hat and it flies through the air

Ticket imported from: #3599398. Ticket imported from: bugs/6218.

Attachments (1)

KQ4.md5 (2.8 KB ) - added by SF/envisaged0ne 7 years ago.
md5 file

Download all attachments as: .zip

Change History (6)

comment:1 by digitall, 7 years ago

Summary: Hat doesn't go off screen during introSCI: KQ4 - Hat doesn't go off screen during intro

comment:2 by digitall, 7 years ago

KQ4 has a number of variant versions, so it would be helpful to be sure of your exact version.

Please could you attach a text file to this bug containing a file listing of your KQ4 datafiles, preferably with file md5sums? The output of a tool such as this: http://md5summer.org or other tool from http://wiki.scummvm.org/index.php/Reporting_unknown_MD5_checksums would be optimal.

Can you also please test this with previous versions of ScummVM i.e. v1.5.0 back to v1.2.0 and confirm if this is a regression and thus when this problem was introduced? This will greatly reduce the amount of work involved in locating the cause of this bug.

by SF/envisaged0ne, 7 years ago

Attachment: KQ4.md5 added

md5 file

comment:3 by SF/envisaged0ne, 7 years ago

I added the md5 file that was created. Please let me know if that's what you needed or if I need to include anything else. The version of KQ4 I'm running is 1.000.111. I tested it on ScummVM 1.2 & 1.5 and it produces the same effect

comment:4 by bluegr, 7 years ago

md5summer is not the way to create checksums, as it calculates the checksum of the whole file contents. We only need the checksums of the first 5000 bytes. The wiki page linked contains instructions on how to create checksums.

Anyway, for reference: This is the early SCI0 version of KQ4 (version 0.000.274), the SCI interpreter used is SCI0 early. This does not happen in the newer version of the game (SCI0 late).

The affected room is 120 (the credits/intro room)

comment:5 by sluicebox, 4 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

I have this exact version of KQ4 and this ScummVM bug no longer occurs. Great job, somebody!

Note: See TracTickets for help on using tickets.