Opened 7 years ago

Closed 7 years ago

#6216 closed defect (invalid)

SCI: Freddy Pharkas (German) - crash when go in saloon

Reported by: SF/windlepoons Owned by:
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

I wanted replay the german version of Freddy Pharkas, but the game crashed with ingame console when Freddy go to Saloon in 1.Act.
Works with stable version 1.3.1, but not higher.

Console message:
User picked target 'freddypharkas-de' (gameid 'sci')...
Looking for a plugin supporting this gameid... SCI [SCI0, SCI01, SCI10, SCI11]
Starting 'Sierra SCI Game'
parameter 0: 0000:0009 (integer), should be null, reference
[VM] kStrLen[46]: signature mismatch via method Print::addTextF (room 670, script 921, localCall 0xed)!

Game version: Freddy Pharkas Floppy german v1.000
OS: aptosid 64bit

Ticket imported from: #3599342. Ticket imported from: bugs/6216.

Attachments (2)

checksum.txt (3.1 KB ) - added by SF/windlepoons 7 years ago.
checksums from Freddy Pharkas German
freddypharkas-de.005 (38.1 KB ) - added by SF/windlepoons 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 by digitall, 7 years ago

Summary: SCI: Freddy Pharkas german - crash when go in saloonSCI: Freddy Pharkas (German) - crash when go in saloon

comment:2 by digitall, 7 years ago

This looks like a script bug in the Freddie Pharkas German datafiles which is detected by newer versions and thus the SCI interpreter halts... Earlier versions didn't do this, resulting in game state corruption and some very weird bugs.

I can add a workaround for this, but it would be useful to identify your exact version so we can find a copy to test with.
Please could you attach a text file to this bug containing a file listing of your Freddy Pharkas German datafiles, preferably with file md5sums? The output of a tool such as this: http://md5summer.org or other tool from http://wiki.scummvm.org/index.php/Reporting_unknown_MD5_checksums would be optimal.

by SF/windlepoons, 7 years ago

Attachment: checksum.txt added

checksums from Freddy Pharkas German

comment:3 by SF/windlepoons, 7 years ago

I added the checksums (md5sum).

comment:4 by bluegr, 7 years ago

I can't reproduce this - I entered the saloon and no error came up. Please attach a savegame where this occurs.

by SF/windlepoons, 7 years ago

Attachment: freddypharkas-de.005 added

comment:5 by SF/windlepoons, 7 years ago

Despite requesting a status update, no further information
on this tracker item has been provided.

As a consequence, I am now closing this item as "Out of
Date". Should you feel that this is not justified, feel free
to re-open it while providing a status update at the same
time, so that we can properly re-evaluate it.

Thank you.

comment:6 by SF/windlepoons, 7 years ago

Sorry, this tracker ID can be closed. I reinstall Freddy Pharkas and now works.

thank you

comment:7 by wjp, 7 years ago

Resolution: invalid
Status: newclosed

comment:8 by wjp, 7 years ago

Ok, thanks for checking.

Note: See TracTickets for help on using tickets.