Opened 7 years ago

Closed 7 years ago

#6210 closed defect (fixed)

SCI: KQ6 Spider scene freezing after picking up paper in web

Reported by: (none) Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

Hello Scummers,
I'm referring here to 2 other bug reports that are indicated "closed", but I suspect that only 1 of them (the earlier one!) is indeed supposed to be closed:

04/2011: https://sourceforge.net/tracker/index.php?func=detail&aid=3291115&group_id=37116&atid=418820
08/2012: https://sourceforge.net/tracker/?func=detail&atid=418820&aid=3555404&group_id=37116

The more recent one happens to have my identical machine/ScummVM version:
Language: English
Version of Game: DOS and Windows version, from the King's Quest Collection disc from Sierra
Platform: Windows 7 64-bit
ScummVM version: 1.5.0

However I can add this new info:
(1) The earlier bug from 04/2011 seems to have been fixed in an earlier ScummVM version.
(2) I tried installing an earlier ScummVM version 1.4.0 64-bit, and open the same saved game: No freeze!
(3) I deduce from this one of the following:
(A) The bug has to do with a 32-bit version of ScummVM on a 64-bit version of Windows 7.
(B) The bug had been indeed fixed somewhere before version 1.4.0, but was somehow re-introduced upon version 1.5.0

Remark: Setting speed to maximum, as suggested for a possible workaround, doesn't seem to make a difference.

Attached is a saved game just before interacting with spider.
To reproduce:
Load, look at the spider, pull the loose web on the bottom and then pick up the piece of paper that is stuck in the web.

Hope that helps.
Your platform is beautiful, keep up the good work!
Sincerely,
Ohad

Ticket imported from: #3596335. Ticket imported from: bugs/6210.

Attachments (1)

kq6-win.016 (44.9 KB ) - added by SF/*anonymous 7 years ago.
Game save just before interacting with spider

Download all attachments as: .zip

Change History (9)

by SF/*anonymous, 7 years ago

Attachment: kq6-win.016 added

Game save just before interacting with spider

comment:1 by digitall, 7 years ago

Summary: Spider scene freezing after picking up paper from webSCI: KQ4 Spider scene freezing after picking up paper in web

comment:2 by (none), 7 years ago

Update: User tdhs changed my summary to contain the words "SCI: KQ4", but the game involved is "SCI: KQ6".
I've re-updated the summary.

comment:3 by (none), 7 years ago

Summary: SCI: KQ4 Spider scene freezing after picking up paper in webSCI: KQ6 Spider scene freezing after picking up paper in web

comment:4 by bluegr, 7 years ago

I can't reproduce this here, and I can't load your saved game :(

I tried the following 3 versions:
- KQ6 DOS floppy English
- KQ6 DOS CD
- KQ6 Windows CD (same resource files as the DOS version)

I couldn't reproduce this issue with any of the 3 aforementioned versions.
I just teleported to the spider room (room 460), examined the web, pulled it and picked up the note. The game doesn't freeze for me...

Tried this on Win 7 64-bit, with the Adlib, MT-32 and GM music drivers.

comment:5 by SF/nkomp18, 7 years ago

Definitely still happening.

Tried all sorts of ways to get past that scene, but failed.
Would be very grateful if someone could upload a safe file after the interaction with the spider, as opposed to before.

comment:6 by bluegr, 7 years ago

I really can't use your saved game with my Windows version of the game. Have you applied any script patches to your game?

comment:7 by bluegr, 7 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:8 by bluegr, 7 years ago

Fixed (with a hack) in commit f019d5a - the fix should be available in the next daily version

Note: See TracTickets for help on using tickets.