Opened 17 years ago

Closed 17 years ago

Last modified 12 months ago

#620 closed defect (fixed)

ALL: Crash when saving

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

Recent CVS snapshots have a bug related to the new
save/load code that causes ScummVM to crash with an
invalid array size 0 error when you try to save. This
is caused by the line

MK_OBSOLETE(ScriptSlot, unk5, sleByte, VER_V8, VER_V10),

in the scriptSlotEntries[] array. Apparently it's not
permitted to have an obsolete entry that is valid for
the current savegame version.

Unfortunately I have no idea if this means the max
version on this line should be lowered to VER_V9 or if
the current savegame version should be bumped to to
VER_V11.

Ticket imported from: #651310. Ticket imported from: bugs/620.

Change History (3)

comment:1 by fingolfin, 17 years ago

Neither nor, saveArrayOf() has to be adjusted, but since my
local checkout is modified with the LZO code, I need to do
that on a seperate checkout.

Bascially, there needs to be added an
if (datasize == 0)
// do nothing
else if (datasize == 1)
...

Just like there is in loadArrayOf()

comment:2 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:3 by digitall, 12 months ago

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.