Opened 7 years ago

Closed 7 years ago

Last modified 13 months ago

#6178 closed defect (fixed)

TOOLS: Fail to build with recent boost & gcc

Reported by: SF/lorem-ipsum Owned by: lordhoto
Priority: normal Component: Tools
Keywords: build Cc:
Game:

Description

ScummVM Tools (1.4.0) fail to build with recent versions with boost (I can confirm it with 1.49.0 and 1.51.0) if the compiler is a version of gcc-4.7 (I'm using 4.7.2, but also see report here: https://bugs.gentoo.org/show_bug.cgi?id=422769)
According to that bug report at boost it's a failure of ScummVM in the usage of intrusive_ptr: https://svn.boost.org/trac/boost/ticket/6943
I constructed a patch adding the necessary using boost::intrusive_ptr... in the necessary places.

Ticket imported from: #3582864. Ticket imported from: bugs/6178.

Attachments (1)

scummvm-tools-boost.patch (1.2 KB ) - added by SF/lorem-ipsum 7 years ago.
Patch to fix the build failure

Download all attachments as: .zip

Change History (6)

by SF/lorem-ipsum, 7 years ago

Attachment: scummvm-tools-boost.patch added

Patch to fix the build failure

comment:1 by lordhoto, 7 years ago

Owner: set to lordhoto
Resolution: fixed
Status: newclosed

comment:2 by lordhoto, 7 years ago

Seeing that bug report you have linked there this looks like the proper solution: "You should define intrusive_ptr_add_ref and intrusive_ptr_release in the namespace of the class, not in namespace boost. "

That works fine with me, so I committed that change as 36cb68919303bc2b874a5faa879e269a35874eff.

comment:3 by SF/lorem-ipsum, 7 years ago

Nice. Wasn't able to get that working (misunderstood explanation).
Thanks for the quick fix.

comment:4 by lordhoto, 7 years ago

Summary: ScummVM Tools fail to build with recent boost & gccTOOLS: Fail to build with recent boost & gcc

comment:5 by digitall, 13 months ago

Component: Tools
Note: See TracTickets for help on using tickets.