Opened 7 years ago

Closed 7 years ago

#6177 closed defect (worksforme)

SCUMM: ZAK - Can't Control Dolphin with Blue Stone

Reported by: SF/ronnsens Owned by: digitall
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Hi there,

inthe bus on mars I can not reach anything .

This problem is only WITHIN the bus - after entering the bus

Then there is a problem, if i want to swim with the dolphin.
When i use the blue stone i cant controll the dolphin.
I can do nothing till the "alien" appears and brings me in prison

Ticket imported from: #3582630. Ticket imported from: bugs/6177.

Attachments (4)

zak-v2-de.s04 (7.7 KB ) - added by SF/ronnsens 7 years ago.
Dolphin Bug
zakmckrk.md5 (2.5 KB ) - added by SF/ronnsens 7 years ago.
MD5CheckSumm from *.lfl files
zak-v2-de.s06 (8.0 KB ) - added by SF/ronnsens 7 years ago.
Dolphin Bug for ScummVM 1.4.0 64 bit
zak-v2-de.2.s04 (8.0 KB ) - added by SF/ronnsens 7 years ago.
Dolphin V 1.0.0

Download all attachments as: .zip

Change History (26)

comment:1 by digitall, 7 years ago

Summary: Problems on Mars, and swimming with the dolphinSCUMM: ZAK - Mars Bus and Dolphin Problems

comment:2 by digitall, 7 years ago

ronnsens: Please search the bug database before opening a new bug, as the first issue you have reported is a known Open bug i.e. Bug #3526089 - "SCUMM: ZAK Can't get objects in the bus on Mars":
http://sourceforge.net/tracker/?func=detail&aid=3526089&group_id=37116&atid=418820

comment:3 by digitall, 7 years ago

ronnsens: Also, your report lacks some details to enable us to proceed with investigation of the cause as this bug has only previously been reported on German versions.

Can you provide the following:
1. Please attach a savegame from the DOS version, in the bus and any
detailed instructions needed to replicate the bug. This will enable us to
replicate and investigate quickly without having to replay the game to this
point.
2. Please list the version of ScummVM you are using and your Operating
System? i.e. ScummVM v1.5.0 latest stable on Win32.
3. Please can you also attach a text file to this bug containing a file
listing of your ZAK datafiles with MD5sums so we can check that this is not
due to corruption in your datafiles from a bad media copy. The output of a
tool such as http://md5summer.org/ would be optimal.

by SF/ronnsens, 7 years ago

Attachment: zak-v2-de.s04 added

Dolphin Bug

comment:4 by SF/ronnsens, 7 years ago

Hi,

at first, sorry for this mars post, didntfsee that there is an other thread about this.
I attached a save filre fot the "dolphin bug"
You just need to use the blue cristall with the dolphin, and then you will see that nothing is happened. After a while its possible to controle zak again, but then the alien appers. So there is is no way to control the dolphin.

Im using the latest Version of ScummVM (1.5.0 - Jul 21 2012)

by SF/ronnsens, 7 years ago

Attachment: zakmckrk.md5 added

MD5CheckSumm from *.lfl files

comment:5 by SF/ronnsens, 7 years ago

Just added the md5 checksum container from the 00-058 LFL files

comment:6 by SF/ronnsens, 7 years ago

I tried the ScummVM 1.40 (Nov 11 2011) 64 Bit version.
With this version the stuff on mars works, but the dolphin is stil buggy :(

comment:7 by SF/ronnsens, 7 years ago

i tried different versions of ScummVM.
On every version i used, the dolphin bug is there.
maybe its because i use win7 64 bit ?

comment:8 by digitall, 7 years ago

ronnsens: No. There are known regressions in Zak V2 DOS (possibly only German), but I can replicate with English between v1.4.0 and v1.5.0. Since your savegame makes it clear you are running a German version, it is likely that these are both related to the same issue.

Since we already have an open bug for the Mars Bus issue, I would close this bug as a duplicate normally, but as you have indicated the Dolphin issue, I will leave this open to track that.

I assume that your attached savegame comes from V1.5.0...

Zak lacks boot params to jump to this point in the game:
http://wiki.scummvm.org/index.php/Boot_Params and the attached savegame
would load in v1.5.0, but not in earlier version such as v1.4.1.

If you could play to this point and attach a v1.4.1 savegame (which
v1.5.0 can load as we maintain backward compatiblity here as far as
possible), then I can look at bisecting to work out where this regression
was introduced.

comment:9 by digitall, 7 years ago

Summary: SCUMM: ZAK - Mars Bus and Dolphin ProblemsSCUMM: ZAK - Can't Control Dolphin with Blue Stone

comment:10 by SF/ronnsens, 7 years ago

Hi,

i havent found a 1.41 version for windows, so i used the 1.4.0 version.
i attached the file below

by SF/ronnsens, 7 years ago

Attachment: zak-v2-de.s06 added

Dolphin Bug for ScummVM 1.4.0 64 bit

comment:11 by digitall, 7 years ago

Summary: SCUMM: ZAK - Can't Control Dolphin with Blue StoneSCUMM: ZAK German - Can't Control Dolphin with Blue Stone

comment:12 by digitall, 7 years ago

ronnsens: The Mars Bus bug was a recent regression and is now fixed in the latest development build. If you want to test with this, you can download here: http://www.scummvm.org/downloads/#daily

So the remaining issue is the Dolphin problem. I am attaching a savegame for Zak V2/DOS/English for reference, as we can NOT replicate with the English version currently, so this looks like either a 64-bit or German version issue, probably the German version.

Could you please test with previous Win32 releases to see if this is a regression or has always been broken...
https://sourceforge.net/projects/scummvm/files/scummvm/

comment:13 by bluegr, 7 years ago

Summary: SCUMM: ZAK German - Can't Control Dolphin with Blue StoneSCUMM: ZAK - Can't Control Dolphin with Blue Stone

comment:14 by bluegr, 7 years ago

Note that this only happens in the German version. The English version works fine.

Since the OP mentioned that version 1.4.0 doesn't work either, it seems like this is an older bug that affects this version

comment:15 by bluegr, 7 years ago

Sorry, meant "...that affects this version of the game"

comment:16 by digitall, 7 years ago

As far as can be determined, the German V2 version of Zak was last successfully tested during v1.0.0 release testing: http://wiki.scummvm.org/index.php/Release_Testing/1.0.0
This was tested on Aug 15 2009
So if this version i.e. e7469479ceebf341322fafbcbddd9028e8a42060 is used as a basis to generate savegames and confirm the bug is not present, then the savegames are loaded into a newer version i.e. if v1.5.0 won't load back that far, then you can use v1.2.0 or similar... as long as you can find a "good" and "bad" version for a coarse bisection.

Then a full bisection with the savegame can be performed to locate the exact regressive commit.

comment:17 by SF/ronnsens, 7 years ago

Hi,

i tried to complete this part with the ScummVM Version 1.0.0
But in this version its still buggy.
I added a savegame from version 1.0.0

by SF/ronnsens, 7 years ago

Attachment: zak-v2-de.2.s04 added

Dolphin V 1.0.0

comment:18 by digitall, 7 years ago

ronnsens: Hmm.. That implies that the issue was introduced between that revision and the release tagging for v1.0.0.

Could you please test with the previous version, 0.13.1 from a new game start and attach a savegame from that version please?

If this doesn't show the problem, then could you repeat this with v1.0.0rc1...

Sorry about this, but once we know approximately when the regression was introduced, we can start to solve it..

comment:19 by digitall, 7 years ago

ronnsens: Can you also confirm if you have remembered to get the training from the guru in KATMANDU? If not, then you can't control the dolphin with the Crystal. See this walkthrough: http://www.zak-site.com/walkthrough.htm

comment:20 by digitall, 7 years ago

Status: newpending

comment:21 by bluegr, 7 years ago

Despite requesting a status update, no further information
on this tracker item has been provided.

As a consequence, I am now closing this item as "Out of
Date". Should you feel that this is not justified, feel free
to re-open it while providing a status update at the same
time, so that we can properly re-evaluate it.

Thank you.

comment:22 by bluegr, 7 years ago

Owner: set to digitall
Resolution: worksforme
Status: pendingclosed
Note: See TracTickets for help on using tickets.