Opened 8 years ago

Closed 8 years ago

Last modified 2 years ago

#6167 closed defect (invalid)

GUI: Sometimes Engine tab does not appear

Reported by: SF/captainjei Owned by: lordhoto
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game:

Description

I've been changing the settings of various SCI games using the Edit Game button, and I noticed that on two different games (Quest for Glory 2 and Space Quest 3) there was no 'Engine' tab. I tried restarting ScummVM several times, and had the same result. I tried playing the games a few times, THEN tried editing the details, and the Engine tab was back.

I don't know how to replicate this, but if I figure it out, I'll leave a comment.

ScummVM version: 1.6.0git2007-gca256a2 (Oct 19 2012 11:21:38) Platform: Windows 7

Ticket imported from: #3578622. Ticket imported from: bugs/6167.

Change History (4)

comment:1 by lordhoto, 8 years ago

This is standard behavior for old game entries, see the NEWS file:

- Added custom game and engine options in the AGI, DREAMWEB, KYRA, QUEEN, SKY and SCI engines. It is now possible to toggle these options via the Engine tab when adding or editing a configuration for a game. In most cases, you will have to run each game once or readd them all in ScummVM's launcher in order to get the custom options tab.

Also this in the README:

8.2) Custom game options that can be toggled via the GUI ---- --------------------------------------------------- A lot of the custom game options in the previous section can be toggled via the GUI. If a custom option is available for a specific game, a new tab called "Engine" will appear when adding or editing the configuration of that game. If the custom options are not shown, the games in question will need to be run once or readded in the ScummVM launcher's game list. This will update the configuration of each entry, allowing the custom options to be shown.

So did you add the game entries before 1.5.0?

comment:2 by SF/captainjei, 8 years ago

I added them under 1.4.x This explains it. Sorry for the invalid report.

comment:3 by lordhoto, 8 years ago

Owner: set to lordhoto
Resolution: invalid
Status: newclosed

comment:4 by digitall, 2 years ago

Component: Engine: SCI
Note: See TracTickets for help on using tickets.