Opened 7 years ago

Closed 7 years ago

#6166 closed defect (fixed)

SCI: Slater & Charlie - Some speech missing

Reported by: SF/captainjei Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: detection Cc:
Game: Slater & Charlie Go Camping

Description

Some of the speech doesn't play on the selection menus. (e.g. "To have the story read" "Do you want to quit?" " To play your favorite page") However, the "Okay!" always plays, and the narrator during the readings plays just fine.

ScummVM version: 1.6.0git2007-gca256a2 (Oct 19 2012 11:21:38)
Language: English
Game version: CD (Sierra Originals)
Platform: Windows 7

Ticket imported from: #3578617. Ticket imported from: bugs/6166.

Change History (9)

comment:1 by bluegr, 7 years ago

This is a duplicate of bug 3554709:
https://sourceforge.net/tracker/?func=detail&aid=3554709&group_id=37116&atid=418820

Check that bug for further details. This has been fixed in the daily version of ScummVM.

comment:2 by bluegr, 7 years ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed

comment:3 by bluegr, 7 years ago

Resolution: duplicate
Status: closednew

comment:4 by bluegr, 7 years ago

Reopening, as captainjei has contacted me saying that he's still having issues with the game in the latest daily version

comment:5 by SF/captainjei, 7 years ago

Okay, as it turns out, the missing speech is played when the default audio settings are used (which uses Adlib music).

It seems that changing the default settings to anything at all causes the speech to not be played. I tried it with MT32 emulation, GS Wavetable synth, Adlib, PCJr, and PC internal speaker, all with the same results: digital sounds and most speech were played, with the exceptions being the speech snippets indicated in my original bug report.

Last version of ScummVM tested on: win32 1.6.0git2021-g228785e (Oct 23 2012 14:36:49)

comment:6 by wjp, 7 years ago

I'm not sure what you mean exactly. Do you mean the problem is triggered by the "Override global audio settings" checkbox? Or by an individual setting?

comment:7 by SF/captainjei, 7 years ago

I mean that the problem seems to be triggered by the "Override global audio settings" checkbox.

comment:8 by bluegr, 7 years ago

Keywords: detection added
Resolution: fixed
Status: newclosed

comment:9 by bluegr, 7 years ago

This was caused by incorrect game entries. Fixed in commit #2c5769c. You will need to remove and readd Slater to your ScummVM list of games (so that the "no speech" flag will get removed). The fix should be available in the next daily version of ScummVM

Note: See TracTickets for help on using tickets.