Opened 7 years ago

Closed 7 years ago

#6159 closed defect (fixed)

SCI: QFG1VGA: Palette/hue bug after loading

Reported by: bluegr Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 1

Description

This is a resubmission of bug #6156 submitted to the trac tracker by the user misterhands:
https://sourceforge.net/p/scummvm/bugs/6156/

Latest SCUMMVM Win 64 build
QFG1 VGA ENG
Load Save 000
Then load Save 001 or 002.
Despite save 001 and 002 being mid-day time, they now exhibit the nightly bluish hue, and in a weird, corrupted way.
Some rooms do not have this problem, see the Save 003 as an example.
This bug does not always show up, so try again if it doesn't.
I have found that the delay before loading the 001 and 002 saves seems to be a factor.
If you load 001 or 002 immediately after hitting the F7 key, the bug doesn't happen.
If you wait longer at the thumbnails loading screen (2 seconds or more) before loading 001 or 002, the bug occurs every time.
Same behavior with the classic savegame list view.

Thanks !

Ticket imported from: #3575569. Ticket imported from: bugs/6159.

Attachments (1)

Saves.zip (195.8 KB ) - added by bluegr 7 years ago.

Download all attachments as: .zip

Change History (11)

by bluegr, 7 years ago

Attachment: Saves.zip added

comment:1 by bluegr, 7 years ago

Well, "Save 001" is corrupted. Perhaps this is what causes the oddities with the game palette?

I can't reproduce this at all, plus it seems kind of impossible to happen, so I believe that the issue you're having is caused by invalid memory access caused by the corrupt save game. If you try without the corrupt save game, do you still get this problem?

comment:2 by bluegr, 7 years ago

Quite an edge case

Fixed in 3b5e92d, the fix should be available in the next daily version of ScummVM

comment:3 by bluegr, 7 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:4 by bluegr, 7 years ago

Reopening, as the OP is still experiencing this bug. I can't reproduce it at all :(

comment:5 by bluegr, 7 years ago

Resolution: fixed
Status: closednew

comment:6 by misterhands, 7 years ago

Basically it happens when you save during dusk or dawn, as the palette is being changed to simulate the day/night cycle.
The palette effect is saved as it should in the 1rst savegame, but when you load another save after that, in some cases some of that palette effect is carried over onto the 2nd save, corrupting the palette.

I just reproduced the situation quite easily, and made another set of saves.
Unfortunately since you stole my bug ;-), I can't attach them here.
Here is a link to them (no sign-up necessary) :
http://www.filedropper.com/palettebug

So to be clear, load the first save (Time Bug), hit F7, wait long enough as described in my bug report, and then load the 2nd save.

Hopefully that will allow you to replicate the issue !

comment:7 by bluegr, 7 years ago

OK, managed to replicate this now.

It was a bug during loading, a variable wasn't always set correctly. Fixed in
commit fb0788d, the fix should be available in the next daily version.

Please check if it has been fixed for you now, so that the bug can be closed.

comment:8 by misterhands, 7 years ago

Yes this is fixed, glad we were able to sort this out !
You can close this now.

Thanks !

comment:9 by bluegr, 7 years ago

Resolution: fixed
Status: newclosed

comment:10 by bluegr, 7 years ago

Glad it's sorted now :) closing

Note: See TracTickets for help on using tickets.