Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6147 closed defect (fixed)

TOUCHE: Assertion Talking to Innkeeper with French Subtitle

Reported by: SF/oldgame Owned by: wjp
Priority: normal Component: Engine: Touche
Version: Keywords:
Cc: Game: Touché: The Adventures of the Fifth Musketeer

Description

All scummvm version on windows 7 pro 64bits, CD version of touche with english talkie and french subtitles.

In St Quentin, When I speak to the innkeeper the game crash and close scummvm. The error message is assertion failed: chr >= 32 && chr < 32 + _fontsize, file engines/touche/graphics.cpp, line 90

Please help...

Ticket imported from: #3571138. Ticket imported from: bugs/6147.

Attachments (2)

touche-fr.1 (2.6 KB ) - added by SF/oldgame 9 years ago.
savegame
Touché.md5 (2.5 KB ) - added by SF/oldgame 9 years ago.
MD5

Download all attachments as: .zip

Change History (13)

by SF/oldgame, 9 years ago

Attachment: touche-fr.1 added

savegame

comment:1 by digitall, 9 years ago

Summary: Touche: the game close after speaking the innkeeperTOUCHE: Assertion Talking to Innkeeper with French Subtitle

comment:2 by digitall, 9 years ago

oldgame: Please attach a text file to this bug containing a file listing of your Touche French datafiles with file md5sums. The output of a tool such as http://md5summer.org/ would be optimal. This is to allow us to uniquely identify your version and eliminate corrupted datafiles as a cause of this bug.

comment:3 by digitall, 9 years ago

Can't replicate the issue with the attached savegame on my English variant.

oldgame: It would also be useful if you could confirm if this has ever worked in previous versions of ScummVM. If you could confirm this by testing previous versions back to the first release with Touche i.e. 0.10.0, then this would be useful.

by SF/oldgame, 9 years ago

Attachment: Touché.md5 added

MD5

comment:4 by SF/oldgame, 9 years ago

MD5 attached

comment:5 by wjp, 9 years ago

Do you have to talk about anything in particular?

comment:6 by SF/oldgame, 9 years ago

I have tried with the older versions 1.0 and above and it doesn't work, I have the same error massage.

comment:7 by digitall, 9 years ago

oldgame: Which dialog option causes the assertion? Please report in french. (This is what wjp meant in his question).

Could you also please test the versions from 0.10.0 to 1.0.0, to determine if this has always occurred, or if this is a regression.

wjp: I thought that this was very close to the start of the game, but that is the Rouen Tavern.. This is some way in, but could be a french charset issue with a lesser used character/accent.

comment:8 by digitall, 9 years ago

Comparing my English version datafiles to the reported MD5sums shows only the expected main executable, installer and database datafile differ:

English: 6de2714bef18056f93fcf6e160be8a66 database/touche.dat 89b11ed913fa83876035d93948dde3b3 install.exe 9720167b50f434603d46a9822f0f1f8c touche.exe

French: dabc88d12a7468e1e72185570efdac34 database/touche.dat 62a03868deb065d8fd623c98b250e026 install.exe ee1c61c943b9b0bb380cedf3473e7075 adventure.exe

comment:9 by SF/oldgame, 9 years ago

There is no option dialogue in particular. When I ask the question to the innkeeper in a different order, That's still after third questions that scummvm close. The question are: Merci, aubrgiste. Ce sera tout. Qu'avez-vous à m'offrir, patron? Y'a-t-il quelque chose à boire? Qui est cet officier, à cette table? Qui est cet homme assis près du feu? Avez-vous vu récemment à Saint-Quentin un nouveau venu...

I found the error. In fact, in the question list there are more than six questions and when go to the seventh questions, scummvm close. This question have special character/accent ? I don't know because it's no appear in the game, the game crash.

How to find this text ? It's possible to use the savegame in the DOS version ?

The bug is since the 0.10.0 version.

comment:10 by wjp, 9 years ago

Should be fixed in the nightly build (by c18cacc248).

comment:11 by wjp, 9 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.