Opened 18 years ago

Closed 18 years ago

#613 closed defect (fixed)

INDY4 CD: Tikal bird...

Reported by: SF/andrej4000 Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

After getting the lamp in tikal you can talk to the bird. After you want to talk the second time, the game hangs...

Happens in the english talkie version. (savegame attached)

didn't test with other versions...

Ticket imported from: #649540. Ticket imported from: bugs/613.

Attachments (1)

atlantis.s01 (46.2 KB ) - added by SF/andrej4000 18 years ago.
Talk to the bird 2 times…

Download all attachments as: .zip

Change History (4)

by SF/andrej4000, 18 years ago

Attachment: atlantis.s01 added

Talk to the bird 2 times...

comment:1 by eriktorbjorn, 18 years ago

I've submitted some possible fixes for this to the patch tracker. See patch #650135.

The problem is that the script is waiting for Sophia to stop moving, when she isn't even present. Apparently the original interpreter handles this case more gracefully than ScummVM does.

comment:2 by eriktorbjorn, 18 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:3 by eriktorbjorn, 18 years ago

This should be fixed in CVS now.

Note: See TracTickets for help on using tickets.