Opened 7 years ago

Closed 2 months ago

#6129 closed defect (fixed)

ANDROID: surface update issues when focus is lost

Reported by: SF/nightsmaiden Owned by: ccawley2011
Priority: normal Component: Port: Android
Keywords: Cc:
Game:

Description

When a popup message (in my case, a text message popup from Handcent) displays over SCUMMVM, the screen freezes. Sound continues, however. I suspect this is basically the same as Artifact 3178197, but with a slightly different trigger that was not anticipated (losing focus without losing the screen).

I first experienced this with version 1.5, current in the Market. I just tested with the latest nightly, and the same glitch occurs.
I am using a MyTouch 4G Slide, aka HTC Doubleshot.
My phone is rooted, and I am running MikTouch 0.7, which is a cleaned-up version of the stock Gingerbread ROM.
I have experienced this mostly with Woodruff and the Schnibble, as that is the game I have played most. I do not recall if I have gotten texts while other games were up.

Ticket imported from: #3559979. Ticket imported from: bugs/6129.

Change History (8)

comment:1 by SF/nightsmaiden, 7 years ago

It is possible to clear the glitch by expressly leaving and returning to SCUMMVM (i.e., hitting the Home button) and coming back in before the system kills SCUMMVM for memory. Sometimes this gives quite a long delay, sometimes out-and-in isn't fast enough to avoid being returned to the menu.

Activity definitely continues in SCUMMVM- the character moves, dialogue continues, etc. Updates just aren't written to the screen.

This does happen in multiple games and the main launcher.

comment:2 by fuzzie, 7 years ago

Owner: set to fuzzie
Summary: Android: Freezes When OverlainANDROID: surface update issues when focus is lost

comment:3 by fuzzie, 7 years ago

I think 3178197 describes a different issue, but maybe. I can't reproduce this at first try. Could you please provide the log (from e.g. aLogCat) from right after this happens?

comment:4 by csnover, 2 years ago

Component: Ports

comment:5 by digitall, 12 months ago

Component: PortsPort: Android

comment:6 by ccawley2011, 2 months ago

Owner: changed from fuzzie to ccawley2011
Resolution: fixed
Status: newpending

This should hopefully be fixed by ​https://github.com/scummvm/scummvm/pull/1695.

comment:7 by Cameron Cawley <ccawley2011@…>, 2 months ago

In 475eafc6:

ANDROID: Don't deinitialize the EGL surface when pausing the application

Fixes Trac#6129

comment:8 by ccawley2011, 2 months ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.