Opened 7 years ago

Closed 2 years ago

Last modified 12 months ago

#6123 closed defect (invalid)

ANDROID: After OS Update 4.1.1, Right-click Button Fails

Reported by: SF/brettmcbride Owned by: dafioram
Priority: normal Component: Port: Android
Keywords: Cc:
Game:

Description

ScummVM version: 1.5.0
Platform: Android 4.1.1 (jelly bean) on Google Nexus S

My phone updated itself to android 4.1.1 today. The search button (which used to act as a right click in android 4.0.4) now goes to a google search screen.

Ticket imported from: #3556233. Ticket imported from: bugs/6123.

Change History (10)

comment:1 by bluegr, 7 years ago

As stated in the forums:

Seems like something has been changed in the Android SDK with jelly bean. Other apps seem to suffer from the same issue:
http://productforums.google.com/forum/m/#!msg/mobile/Axu9w7KOhjY/0mFEyQd8CVAJ

As a workaround, there is a mod that fixes the search button to not perform a Google search when running an app:
http://forum.xda-developers.com/showthread.php?t=1788719

comment:2 by digitall, 7 years ago

Summary: android 4.1.1 right click does not workANDROID: After OS Update 4.1.1, Right-click Button Fails

comment:3 by fuzzie, 7 years ago

Owner: set to fuzzie

comment:4 by fuzzie, 7 years ago

Does your search button work in any apps, or does it always go to the search screen? If Google have hard-wired it to an action on your phone, we can't do anything about it.

comment:5 by SF/brettmcbride, 7 years ago

@fuzzie: I've tried a few other apps, same result. It does seem like the search button has been hard-wired in JB - I'll see about that workaround mod (but I'm hesitant to root my phone, I'm not a hard-core hacker...)

comment:6 by fuzzie, 7 years ago

In that case I'm unfortunately not sure if we can do anything, other than recommend people use the multitouch two-finger tap for right-click. As a project we can't really recommend rooting your phone or applying unofficial system mods. Hopefully someone will find a more sensible workaround, we'll keep an eye out.

comment:7 by bluegr, 7 years ago

There's this application that can be used:
https://play.google.com/store/apps/details?id=com.cleansoft.searchbuttonoverride

This does not require you to root your phone

comment:8 by csnover, 2 years ago

Component: Ports

comment:9 by dafioram, 2 years ago

Owner: changed from fuzzie to dafioram
Resolution: invalid
Status: newclosed

This is not a scummvm problem since the op has stated (comment5) it is common to all applications not just scummvm.

comment:10 by digitall, 12 months ago

Component: PortsPort: Android
Note: See TracTickets for help on using tickets.