Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6120 closed defect (fixed)

SCI: KQ6 Spider Scene Game Freeze

Reported by: SF/kjps86 Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

In King's Quest 6: Heir Today, Gone Tomorrow, when playing either the DOS talkie/CD or Windows talkie/CD version, once you speak to the Black Widow on the Isle of Wonder and pull the part of her web to distract her and snatch the piece of paper from her web, the game becomes stuck with the crown icon for the cursor. You can't change to any other cursor (hand, walk, look, etc.) though you can save the game/quit/change options. You cannot leave the screen or do anything else. I've tried changing the time I attempt this by doing other things in the game first but it doesn't seem to make a difference.

Language: English Version of Game: DOS and Windows version, from the King's Quest Collection disc from Sierra Platform: Windows 7 64-bit and Android 4.04 (problem is identical on both) ScummVM version: 1.5.0 Save game of Windows version is attached. It places you right before you talk to the spider, simply select the eye and click on the web to start interacting with the Black Widow.

Any help is greatly appreciated, I am very grateful for the work the ScummVM has done so far.

Ticket imported from: #3555404. Ticket imported from: bugs/6120.

Attachments (1)

kq6-cd-win.000 (44.1 KB ) - added by SF/kjps86 8 years ago.
Save file from Windows version of game

Download all attachments as: .zip

Change History (9)

by SF/kjps86, 8 years ago

Attachment: kq6-cd-win.000 added

Save file from Windows version of game

comment:1 by digitall, 8 years ago

Summary: Spider scene causes game freezeSCI: KQ6 Spider Scene Game Freeze

comment:2 by digitall, 8 years ago

kjps86: I vaguely recall this issue, but having trouble finding when and if this was fixed.

I think this might be possible to work around by changing the Game Speed to Maximum.. Can I suggest trying this?

comment:3 by digitall, 8 years ago

Ah, located it. Bug #3291115 - "KQ6: Game freezes when getting paper from web" : http://sourceforge.net/tracker/index.php?func=detail&aid=3291115&group_id=37116&atid=418820

This was solved by commit 5654e1257551bf176c7fd06c756612bec3d79033

comment:4 by digitall, 8 years ago

Owner: set to bluegr

comment:5 by SF/kjps86, 8 years ago

Please excuse my ignorance, this is my first time reporting a bug in a piece of software of any kind. I see you say this issue was solved (I visited and reviewed the link you provided)--is there anything I can do to get a version of ScummVM, or compile it from source, that would resolve this issue? Is there a Readme file I should have read beforehand? I'm willing to do the legwork but did not see any info regarding where to start.

Incidentally, I already had the Game Speed set to maximum, it didn't make a difference, though I also didn't try setting it to a lower speed, so I can't be sure if that would have made a difference.

Thanks

comment:6 by digitall, 8 years ago

kjps86: Thank you for being considerate, asking constructive questions and providing sufficient information. That already is helpful. You could try playing this from a new game with v1.2.1, v1.3.1 and v1.4.1 and seeing if you observe the same bug. The fix I mentioned was added between v1.2.1 and v1.3.0 releases, but this may be not directly related.

In terms of other version you could test, I would normally ask you to test with the latest nightly development Git master build from: http://buildbot.scummvm.org/builds.html But since v1.5.0 was only released a short while ago, I doubt this will show any difference. Please feel free to test and report here though if you have time.

Apart from the included README file, NEWS file which cover various issues, we have a wiki which holds more detailed documentation, as well as detailed TODO, known bug in the original game lists etc. I have already checked the SCI engine pages here and not found anything relevant to this: http://wiki.scummvm.org/index.php/SCI

If you find that a previous version does not exhibit this bug, but the current version does, then the next step if you are capable of using a C++ compiler and command line tools is to run a Bisection to locate the regressive commit: http://fiji.sc/wiki/index.php/Pinpoint_regressions_with_Git

The instructions on how to checkout a Git repository of our codebase and build on various platforms can be found on the wiki: http://wiki.scummvm.org/index.php/Developer_Central#Getting_started http://wiki.scummvm.org/index.php/Compiling_ScummVM

comment:7 by bluegr, 8 years ago

Turns out that this was a script bug after all. Fixed in 8524ebd699254a6786033f0e41b9a45c563feb11

comment:8 by bluegr, 8 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.