Opened 7 years ago

Closed 6 years ago

Last modified 13 months ago

#6117 closed defect (invalid)

OSX: GUI appears off-screen on Retina MacBook Pro

Reported by: SF/jacksterd Owned by:
Priority: normal Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

ScummVM version: 1.5.0
Platform: OS X 10.8.0

When running ScummVM full screen in OS X 10.8 on a Retina MacBook Pro, some of the ScumVM GUI appears above the top of the screen and off the right of the screen.

Ticket imported from: #3554632. Ticket imported from: bugs/6117.

Attachments (1)

photo.JPG (61.8 KB ) - added by SF/jacksterd 7 years ago.

Download all attachments as: .zip

Change History (17)

by SF/jacksterd, 7 years ago

Attachment: photo.JPG added

comment:1 by SF/jacksterd, 7 years ago

After a bit more testing I can add the following information:

• Opening ScummVM in fullscreen mode in Graphics Mode 3x or HQ3x results in the offscreen bug as pictured.
• Opening ScummVM in fullscreen mode in Graphics Mode 2x or HQ2x results in the GUI appearing off to the left (whereas it would usually appear in the centre of the screen), but with no impact on its usability.
• All of this occurs with Aspect Ratio Correction enabled. Trying to turn it off gives an error just saying that it cannot be turned off.
• ScummVM works fine in windowed mode
• Sometimes when switching from fullscreen to windowed mode something goes wrong and all you get is a black screen and a larger than usual version of the OS X pointer. As far as I can tell the only way to get out of this is to hold down the power button and reboot.

comment:2 by SF/jacksterd, 7 years ago

To process your bug report appropriately, please be so kind and provide the following information, if you have not done so yet:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by digitall, 7 years ago

Summary: GUI appears off-screen on Retina MacBook ProOSX: GUI appears off-screen on Retina MacBook Pro

comment:4 by digitall, 7 years ago

Assigning to Mac OSX porter for visibility.

comment:5 by digitall, 7 years ago

Owner: set to vinterstum

comment:6 by digitall, 7 years ago

A recently reported bug #3553538 - "DREAMWEB: Crash after intro on OS X 10.8.0" has already indicated that the v1.5.0 release OSX build is suffering from crashes probably associated with Graphics mode change i.e. :
https://sourceforge.net/tracker/?func=detail&aid=3553538&group_id=37116&atid=418820
This is likely a related issue.

jacksterd: Could you confirm here if you observe the same issue when running with the latest Git master development build from: http://buildbot.scummvm.org/builds.html ?

comment:7 by SF/jacksterd, 7 years ago

Hi tdhs,

I have downloaded the latest nightly build and can confirm the issue is still there. However, after doing a bit more testing it looks as if the issue only occurs when the integrated Intel HD 4000 graphics chip is engaged. When the graphics switches to the discrete Nvidia chip it seems as if both 1.5.0 and the latest nightly build function correctly in full screen mode when using 2x, 3x, HQ2x and HQ3x scaling.

comment:8 by SF/jacksterd, 7 years ago

Owner: vinterstum removed

comment:9 by SF/jacksterd, 7 years ago

Hold on, I could be mistaken on that. Give me another 10 mins to check this out some more.

comment:10 by SF/jacksterd, 7 years ago

I'm beginning to think these issues are related to the automatic switching between the Intel and Nvidia graphics chips.

When loading the latest ScummVM nightly while the Intel chip is active, the program either hangs at a black screen for a few seconds then dumps me back to the desktop, or gives me the GUI with bits of it off the screen. If I get a black screen when loading ScummVM then it seems after I quit I'm no longer able to manually switch between graphics chips, and any program which would normally engage the Nvidia chip (e.g. Aperture) now hangs when opening and doesn't seem to be able to switch graphics chips. The only way to get things back to normal is to reboot.

If, however, I manually engage the Nvidia chip before opening ScummVM there are no problems and everything behaves normally. If I then quit ScummVM, manually switch to the Intel chip and then open ScummVM again everything works normally with none of the above issues.

Note - OS X seems to deem ScummVM as a program which benefits from the Nvidia chip and switches (or tries to switch) to the Nvidia chip when the program loads.

comment:11 by digitall, 7 years ago

jacksterd: This sound like a libSDL bug with OSX, rather than a problem with ScummVM:
http://www.libsdl.org/

I'd suggest you try some other games and applications which use libSDL for video/audio/events and see if you get the same issues. See:
http://www.dosbox.com/
http://freeciv.wikia.com/wiki/Main_Page

comment:12 by sev-, 7 years ago

Status: newpending

comment:13 by sev-, 7 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:14 by digitall, 6 years ago

Closing as the submitter is unresponsive.

comment:15 by digitall, 6 years ago

Resolution: invalid
Status: pendingclosed

comment:16 by digitall, 13 months ago

Component: Port: Mac OS X
Summary: OSX: GUI appears off-screen on Retina MacBook Pro OSX: GUI appears off-screen on Retina MacBook Pro
Note: See TracTickets for help on using tickets.