Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6075 closed defect (fixed)

SCI: SQ4 CD crash when restarting after dying

Reported by: misterhands Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Space Quest 4

Description

Using latest win32 build, SQ4 CD

Trying to restart the game after dying results a crash with this error message :

WARNING: SegManager: seg 2a is removed from memory, but not removed from hash_map!
SegManager::deallocate(): invalid segment ID!

I got this from the beginning of the game.
Death by free-fall (near the grate you're supposed to open) results in the mentioned segment being 2a
Death by being shot by the robot (after the zombie screams) results in the mentioned segment being 2b

This is with Speech + Text set to BOTH, but it occurs also when set to TEXT or SPEECH, except the segment in these cases is 26.

This crash DOES NOT happen in 1.4.1.
I suspect it might be caused by the fix of bug #3538418.

Ticket imported from: #3539392. Ticket imported from: bugs/6075.

Change History (3)

comment:1 Changed 7 years ago by bluegr

I added a temporary hack for this (commit f6e4312) - the issue needs to be further investigated, though, so I'm keeping this open

comment:2 Changed 7 years ago by bluegr

Update: the solution in commit f6e4312 is the correct one, and it's not a hack, so this can be closed as fixed

comment:3 Changed 7 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.